Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

Is it possible to disable x and y buttons on gba emulator lr-mgba?



  • I'm using RetroPie version 4.2 on a Raspberry Pi 3. Using the gba emulator lr-mgba, pressing x or y will turbo the a or b buttons, respectively. I could use the lr-vba-next emulator, but the sound was a bit funky when I was testing it on Legend of Zelda: A Link to the Past, so I'd rather not use that one, and lr-gpsp doesn't seem to work at all (whenever I load it up, it just takes me back to the game select screen). Is there any way to just disable the x and y buttons, so they don't do anything when pressed on lr-mgba?



  • I was trying to accomplish the same thing, but couldn't find anything specific. I found a general solution, but it's a bit ugly and it would be better if lr-mgba could add a turbo button enable/disable core option (similar to fceu). I know this is an old thread but hopefully it helps someone.

    Note: If you have a controller without L3 or R3 stick buttons, you can just map all the turbo functions to those buttons from the RetroArch menu and you won't need to do any of this.

    Buttons can be completely disabled by changing them to "nul" in the joypad-specific files in /opt/retropie/configs/all/retroarch/autoconfig but that would affect all cores. You can make the change core-specific by making a copy of those file(s) and putting a joypad_autoconfig_dir line in your gba retroarch.cfg:

    First, open the RetroArch menu while lr-mgba is running and map the turbo A and turbo B buttons to L2 and R2 (the same as turbo L and turbo R default mapping). This way you'll only need to disable those 2 buttons.

    Then make a copy of your joypad configs:

    cp -R /opt/retropie/configs/all/retroarch/autoconfig /opt/retropie/configs/gba/retroarch-joypads

    In each of the .cfg files in the new /opt/retropie/configs/gba/retroarch-joypads directory (if you have more than one type of joypad), change these lines to disable the L2 and R2 buttons:

    input_r2_btn = "nul"
    input_l2_btn = "nul"
    

    Then add to /opt/retropie/configs/gba/retroarch.cfg

    joypad_autoconfig_dir = "/opt/retropie/configs/gba/retroarch-joypads/"
    

    You can comment out that line and re-map turbo A and turbo B to change back to the default behavior later. Be careful not to set any buttons you need to navigate the RetroArch menu to "nul" because it disables them there as well.



  • This post is deleted!


Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.