Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

  • Hello,

    Please, give your views on how to run Retropie (on a Raspberry Pi 3) on my TV set (HDMI) and be able to login remotely from a Windows laptop to an LXDE X session.

    If I configure raspi-config to desktop login and Retropie to desktop autologin, TV will show Retropie (great!) but VNC viewer will show a black screen...

    pi@raspberrypi:~ $ sudo raspi-config
    Removed symlink /etc/systemd/system/default.target.
    Created symlink from /etc/systemd/system/default.target to /lib/systemd/system/graphical.target.
    

    raspi-config: DESKTOP autologin
    RetroPie-Setup: start Emulation Station at boot

    pi@raspberrypi:~ $ sudo systemctl status vncserver-x11-serviced.service
    ● vncserver-x11-serviced.service - VNC Server in Service Mode daemon
       Loaded: loaded (/usr/lib/systemd/system/vncserver-x11-serviced.service; enabled)
       Active: active (running) since Fri 2017-11-17 11:16:13 CET; 52s ago
     Main PID: 839 (vncserver-x11-s)
       CGroup: /system.slice/vncserver-x11-serviced.service
               ├─839 /usr/bin/vncserver-x11-serviced -fg
               └─865 /usr/bin/vncserver-x11-core -service
    
    Nov 17 11:16:13 raspberrypi systemd[1]: Started VNC Server in Service Mode daemon.
    Nov 17 11:16:14 raspberrypi vncserver-x11[865]: ServerManager: Server started
    Nov 17 11:16:14 raspberrypi vncserver-x11[865]: ConsoleDisplay: Cannot find a running X server on vt2
    Nov 17 11:16:14 raspberrypi vncserver-x11[865]: ConsoleDisplay: Found running X server (pid=872)
    Nov 17 11:16:42 raspberrypi vncserver-x11[865]: ConsoleDisplay: Cannot find a running X server on vt1
    

    So VNC server is up and running. And I have managed to display LXDE in the TV set as well by running it from command line with 'startx' so I think it has to do with opening a second X session but how to accomplish it, that I would like to learn about.

    FYI,this is my setup:

    2017-07-05-raspbian-jessie-lite
    sudo apt-get update
    sudo apt-get upgrade
    sudo reboot
    
    LXDE as GUI
    sudo apt-get install --no-install-recommends xserver-xorg
    sudo apt-get install --no-install-recommends xinit
    sudo apt-get install lxde-core
    sudo apt-get install lightdm
    sudo reboot
    
    sudo apt-get install realvnc-vnc-server
    sudo systemctl start vncserver-x11-serviced.service
    sudo systemctl enable vncserver-x11-serviced.service
    sudo reboot
    

    At this point I can log in remotely via VNC Viewer and nice LXDE GUI will show. Blank screen shows after installing Retropie:

    sudo apt-get update
    sudo apt-get dist-upgrade
    sudo apt-get install git
    cd
    git clone --depth=1 https://github.com/RetroPie/RetroPie-Setup.git
    cd RetroPie-Setup
    sudo ./retropie_setup.sh
    

    Thank you in advance for your feedback!

  • administrators

    @derebo pick one or the other. You can't do both

Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.