Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

RetroPie going back to a point in time (snapshot/deepfreeze like)



  • Hi, this is a really weird situation and it doesn't make sense to the extent of the knowledge I have concerning the RetroPie/Raspberry Pi (I am a Windows/VMware Sysadmin with a good knowledge of Linux).

    Concerning installation/modification to the RetroPie, the only thing I've tried to do recently is to install the Sega Dreamcast emulator, Reicast. At 2 occasions, the installation failed and I've ensured removing the folder of Reicast after the failed installation (through the same menu where you can install the optional package).

    That's the only thing I could've done before the problem started to happen, which doesn't seem to be related as far as I'm concerned.

    All of my games (Roms folder) seem to go back to a point in time, hence my reference to a snapshot (virtual machines) or the deepfreeze software in the title. When I opened my RetroPie this morning, I realized that the game I had played and the state I had saved went back in time to an earlier one. At first, I thought it was only this one game, until I realized it was ALL OF THEM!!! :-O

    I have uploaded a new PSX game after and started to play it fine, only to realize after shutting down the RetroPie and rebooting it that the game itself and the state saved were also gone!

    I have no idea what is going on, any thoughts everyone? Thank you in advance for any thoughts you may have.



  • P.S. : I've just done a test : I've uploaded again a new game and when rebooting the RetroPie, it was gone.



  • @vladquebec i would check the free space on the sd card (df-h), maybe the filesystem is full, or needs to be expanded. see: https://github.com/RetroPie/RetroPie-setup/wiki/FAQ#how-do-i-extend-the-available-space-when-upgrading-to-a-larger-sd-card


  • Global Moderator

    @vladquebec Check the permissions on the ROM folders.
    Save states are written when you exit cleanly from the emulator, so make sure you're not restarting by resetting the power during the gameplay or while in ES.
    Give us more info about your setup - https://retropie.org.uk/forum/topic/3/read-this-first



  • When SD cards go bad, they go into read-only mode. This is to allow you to get your data off the card before it dies entirely. My suggestion is to back up your SD card and replace it.



  • @vladquebec Hey please try the following with a new card of equal or more size. I agree with @zerojay, when SD cards go bad there is nothing that can be done other than recovering your data (if lucky).

    sudo dd status=progress if=/dev/mmcblk0 of="retropie.img"
    
    # change sd card to new/spare of equal/more size and then
    sudo dd status=progress of=/dev/mmcblk0 if="retropie.img"
    

    If you get IO error with dd your sd card is kaput.



  • @hex Thanks for the detailed answer. I did try the command, but it doesn't work :

    dd: invalid status flag: ■progress■

    Is there anything I am missing?

    I had thought my SD card was bad, but it's not even a year old. I know problems can happen early, but it seems weird at this point...



  • @vladquebec I don't think I've had a single SD card last anywhere near as long as a year in a pi.



  • @zerojay Thanks for sharing, something new I've learned this week. :-)



  • Follow-up : just ran a surface scan of the SD card, while inserted into my laptop, everything looks fine.

    Don't worry, I know it doesn't mean that's not the problem, but I thought I'd mention it.



  • @mitu Thanks for sharing this, I'll come back with a detailed list of what I have on my side.



  • @mitu Relevant information as requested :

    Raspberry Pi 3 (RPi3) Model B Quad-Core 1.2 GHz 1 GB RAM
    On-board WiFi and Bluetooth Connectivity
    32 GB Micro SD Card (Class 10) - Raspberry Pi Recommended Micro SD Card pre-loaded with NOOBS
    CanaKit 2.5A USB Power Supply with Micro USB Cable and Noise Filter - Specially designed for the Raspberry Pi 3 (UL Listed)
    High Quality Raspberry Pi 3 Case, Premium Quality HDMI Cable, 2 x Heat Sinks, GPIO Quick Reference Card, CanaKit Full Color Quick-Start Guide
    RetroPie Version Used (eg 3.6, 3.8.1, 4.1 - do not write latest): 4.2
    Built From: Pre made SD Image on RetroPie website (retropie-4.2-rpi2-rpi3.img
    USB Devices connected: None
    Controller used: PS3 controller (wireless) and a keyboard/mouse when required (turned off most of the time).
    Error messages received: None in this case.
    Log found in /dev/shm/runcommand.log (if relevant): no such file there, no logs
    Guide used: None
    File: Files in the directory \retropie\roms revert to a previous state when the RetroPie reboots
    Emulator: only default installed emulators, plus lr-ppsspp
    Attachment of config files: N/A
    How to replicate the problem: do a change in any game (upload a new one) and/or save a new state within a game, reboot and check to see if it's still there.



  • @chipsnblip I've had this thought as well, concerning the free space, but it doens't seem to be a problem, here is the result of the df command :

    0_1511040729345_db6e440e-2482-4cc1-86a2-b1db2ed83fe8-image.png



  • @chipsnblip Did an expansion of the drive as recommended, but didn't do anything, reverted back to its original data at startup.

    Found out the problem isn't only with RetroPie, it's with the rest as well : enabling SSH for terminal access reverted to disabled after reboot.



  • Where did you run that command? On your Linux PC I hope.

    If yes you can just skip the "status=progress". It just provides feedback. Without that it will process but you will not get any feedback till the entire process is done.



  • @vladquebec, i'm curious to see if it's a permissions issue somewhere, post the outputs of:

    cat /etc/fstab
    

    and

     cat /boot/cmdline.txt
    

    and

    ls -l /
    

    (no need for sudo)



  • Follow-up of something I've tried : I downloaded the most recent version of RetroPie, 4.3 and completely deleted the 2 partitions on the SD card. The part deleting the largest partition, containing the RetroPie data, took a long time. Right after I unplugged the SD card from the computer that I used to format it, I plugged it into the Raspberry Pi, and the partitions, including the data, were back. This clearly shows the problem is with the SD card.

    At this point there are 2 possibilities (1 more probable than the other) :

    • The SD card has begun to fail and cannot accept any changes.
    • Some sort of read-only mechanism has been enabled, making it impossible to modify anything on the card (less probable, but still a possibility).




  • @vladquebec If you cannot flash imgs to sd card, your sd card is dead. I have one that went dead and partitions/files cannot be changed anymore.



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.