Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

Emulation Station stops responding at No Controllers Detected. Keyboard also halts.



  • Hi all,

    I have an arcade cabinet I am dying to put this in but, have no luck getting anywhere. =/ A similar thread here, was a power issue. This issue, there is no rainbow block to indicate power loss.. I tried a different power source, and that triggered the rainbow block thing.

    System boots into RetroPie then Emulation Station. The Controller config screen comes up, but none of the 4 controllers I try (one is XBox) respond. The keyboard also does not respond. Sometimes the Num Lock key will function but no other key. Eventually that even locks up.

    Followed this tutorial - https://github.com/retropie/retropie-se ... stallation
    RetroPe 4.3 running on external USB drive (Also tried 4.2)

    dev/input is empty
    Ran get-apt update and installed what it gave.
    Raspian detects all controllers and loads successfully, as seen from the boot-up echo.
    Is it possibly firmware not in that update?


  • Global Moderator

    Might still be a power issue. If I have a 2.5" USB drive connected, adding another USB device can cause the drive to lose power, without any visual warning. Maybe try connecting the drive or other peripherals via a powered USB hub, or at least temporarily test on a SD card without the USB drive connected.



  • AHH Thank you, I was assuming all was well without that indicator. =)

    OK now I have a self powered USB drive attached. Confirmed it is powering by unplugging the power source from the Pi and it continued to run. Same issue though.

    So now I need to get a USB hub with its own power source for the keyboard? I am testing with and without controllers attached.



  • Same thing. Safe to say it is not a power issue. Where can I find relevant logs?

    I now have
    an external HDD with its own power supply
    a USB Hub with its own power supply.

    I have tried
    plugging keyboard, USB Hub, and USB drive into the Pi
    plugging everything into the USB Hub, and the Hub connected to the Pi.

    After an insane amount of hours wasted, I am wondering now if RetroPie actually works. =/


  • Global Moderator

    Check the dmesg log and see what input/USB devices are being detected by the kernel. RetroPie is simply a collection of scripts running on Raspbian, so if it works in the plain distribution, it should work here too.



  • @psyke83 said in Emulation Station stops responding at No Controllers Detected. Keyboard also halts.:

    dmesg log
    Well that didnt seem to reveal much. Hardware seems to be fine since it detects the inputs.....



  • Is there an official forum where experts can help???



  • @rasp_renegade Being snarky is definitely going to get you assistance...
    Anyway, you said "RetroPe 4.3 running on external USB drive (Also tried 4.2)" , Are you running from a live bootable Linux dsitro?


  • Global Moderator

    @rasp_renegade Yes, it's called experts-exchange, but its long dead.
    Kidding aside, have you tried updating your Raspbian image via apt-get update && apt-get upgrade ?
    It's strange you say you tried 4.3, but from the dmes output it seems you're runnning an old libraspberry package and since this commit any updates for the RetroPie will trigger the installation of a newer libraspberrypi package.



  • @jonnykesh Sorry, did not mean to come across like that. I mean developers when I say experts. You are an expert compared to me!!! No, I boot from the Pi's microUSB, with commandline pointing to the external HDD where RetroPie is installed from by Image
    @mitu I have the images on four different devices. The one I ran the logs on was a random pick. But I will make sure all of them are at 4.3 now.


  • administrators

    @rasp_renegade man I hate walls of text. Especially on mobile. Please post walls of text on pastebin and provide a link instead



  • @herb_fargus Sorry! I even read that post first. It is here -https://pastebin.com/zupWD24S I deleted the wall.

    @mitu I have the uploaded dmesg running 4.3. When I run sudo apt-get update && apt-get upgrade I get this..

    Fetched 7,822 kB in 32s (238 kB/s)
    Reading package lists... Done
    E: Could not open lock file /var/lib/dpkg/lock - open (13: Permission denied)
    E: Unable to lock the administration directory (/var/lib/dpkg/), are you root?


  • administrators

    @rasp_renegade thanks you're my new favourite person. Try

    sudo apt-get update && sudo apt-get upgrade
    


  • @herb_fargus Well crap, that makes sense, thanks. I ran previously before I extended the file system, now I cannot get the prompt when booed into sda2. (frozen at controller screen). Is there a key combo I can press when the RetroPie logo is displayed, to stop emulationstaton to load?


  • Global Moderator

    @rasp_renegade Try Ctrl+C to interrupt the running program, but if you keyboard is working then press F4 to exit ES.



  • Thanks @mitu !!!!! CTRL-C got it and ,maybe ESC lol

    The update/ upgrade installed a bunch of stuff, but I am still at that dreadful screen that has haunted me for weeks.

    What about logs the lead up to the event of the system crash? var/log/ then would syslog be the best one to look in? I saw nothing useful there.



  • Something that caused me trouble in the past...

    Do you happen to use a fan? Are you using the official power supply?



  • @matchaman Yes it is the power supply that came in the kit. I do not have a fan. Is it required?


  • Global Moderator

    @rasp_renegade Ok, so you got the system updated. Can you try just booting the system with the USB HDD (external powered) and then attaching the keyboard and controllers one by one after boot to see if it's working ? Check the dmesg command after adding the each and see if it's detected.

    Can you post your /etc/fstaband the /boot/config.txt to see how you mounted your partitions and which options you chose for boot ?
    EDIT: in order to temporarily disable EmulationStation from trying to start up, edit the /opt/retropie/configs/all/autostart.sh file and comment (with a # at the beginning of the line) the ES auto-start. You can always start it from the keyboard by just typing emulationstation.



  • No, a fan is not required if you don't overclock but a heatsink is very recommended.

    I was asking because when I used a particular fan, it was hit-and-miss with the gamepad. The fan was drawing too much energy! A different fan of the same size/specs solved the issue.

    As for the power supply, since it's the official, it shouldn't be the cause of such a problem.


Log in to reply
 

Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.