Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

Emulation Station stops responding at No Controllers Detected. Keyboard also halts.



  • Something that caused me trouble in the past...

    Do you happen to use a fan? Are you using the official power supply?



  • @matchaman Yes it is the power supply that came in the kit. I do not have a fan. Is it required?


  • Global Moderator

    @rasp_renegade Ok, so you got the system updated. Can you try just booting the system with the USB HDD (external powered) and then attaching the keyboard and controllers one by one after boot to see if it's working ? Check the dmesg command after adding the each and see if it's detected.

    Can you post your /etc/fstaband the /boot/config.txt to see how you mounted your partitions and which options you chose for boot ?
    EDIT: in order to temporarily disable EmulationStation from trying to start up, edit the /opt/retropie/configs/all/autostart.sh file and comment (with a # at the beginning of the line) the ES auto-start. You can always start it from the keyboard by just typing emulationstation.



  • No, a fan is not required if you don't overclock but a heatsink is very recommended.

    I was asking because when I used a particular fan, it was hit-and-miss with the gamepad. The fan was drawing too much energy! A different fan of the same size/specs solved the issue.

    As for the power supply, since it's the official, it shouldn't be the cause of such a problem.



  • @mitu

    Taking me forever to get back to this!! ......Helping me turn off the autoload was HUGE. Thanks!!! =)

    Running dmesg -wH shows me all four controllers when I connect them by vendor, etc. Two of the controllers have errors, but I will deal with that later.

    Here are the files.

    Config.txt (isnt doing much )- https://pastebin.com/MhWTV7K3
    FSTAB - https://pastebin.com/sDn0D4Wg
    DMESG - https://pastebin.com/PBDLJ0DM (should I boot into RetroPie to get the output?)


  • Global Moderator

    @rasp_renegade So the config file is stock, and so if the /etc/fstab file. I assume the external HDD is auto-mounted by the usbromservice since there's no entry in the /etc/fstab file for it.
    There is no specific error in the dmesg file, but it looks like your keyboard is registered twice. At this point, the only thing that comes into mind is that due to the high number of USB devices connected, the USB hub on the PI is not able to finish initialization during boot.
    What happens if you boot normally - no USB devices connected - then attach the devices one by one, making sure that the USB HDD is the last device connected ?


  • Global Moderator

    The second detection of the keyboard just as the USB drive is probed seems suspicious. That suggests to me that the USB ports are not coping with the load from the external USB drive.

    I have a Pi 3 with the official power brick, a USB drive and a USB keyboard connected. If I try to plug in a DualShock3, my USB drive will either lose power (sudden drive parking) or will give USB errors.

    Try to temporarily take the USB drive out of the equation entirely; test a boot from SD card with nothing but the keyboard connected. If the keyboard operates correctly (and is detected only once), then try to eliminate which component is causing issues, if not the USB drive as I suspect.



  • @mitu I am not sure about the usbromservice. I modified the commandline.txt from Noobs to make it boot to the attached drive. I will try the scenario

    @psyke83 I believe I disconnected then reconnected. If that was the case would it show in that log?



  • I tried booting with only the USB HDD, when it got to the RetroPie login I connected keyboard and typed emulationstation. I tried ES with and without the keyboard (unplug after typing emulationstation) but it freezes as soon as the Emulation Station splash screen appears.

    I have tried 3 different USB HDD, all same symptoms. Every thing detects fine running in Raspian, so it is something not liking the app?

    @psyke83 Do you mean boot into RetroPie from the SD card?



  • Close this thread. I threw that piece of crap away and just bought a new one. =/ Now I have to go through all the setup again.


Log in to reply
 

Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.