Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

  • Hardware:
    Rasberry Pi Model 3 B
    PNY Micro SD card 32GB
    Keyboard/Mouse
    7" touchscreen

    Software:
    RetroPie v4.3 pre made SD image from retropie.

    Issue:
    My Rasberry Pi will not boot to retropie it just shows a blank screen. I have downloaded retropie v4.3, SD card formatter, and windisk32. I download the retropie image for Rasberry pi model 2/3. Extract it to my desktop. I make sure that my SD card is formatted first, then I write the image to the SD card using Windisk32 or Etcher. When I plug in the SD card into my Pi it just shows a blank screen. I have followed the tutorial just like it shows and nothing happens. Any help would be much appreciated.

    Note:
    I have used multiple micro SD cards as well as an extra rasberry Pi ( same model) that has a 16GB card with pre installed Rasbian OS on it. I put that card into my rasberry Pi and rasbian boots fine. I would use this card but I do not want to format it and lose the only operating system that seems to work. Besides the 16GB micro SD card that has the pre installed rasbian OS I also have access to two 32GB micro SD Cards one by PNY and one by Samsung. I have used both to no success. The format for the 32GB cards are FAT32 while for the 16GB card is FAT I have tried to format the 32GB cards into FAT to see if that changes anything but there is no option to do so. I have also connected the rasberry Pi to and TV via HDMI and it is blank as well.


  • @jknudsen97 So the issue has to be with the way you are doing it from the image, or a faulty card. What did you do with the unzipped image? You have to "write" it to the card - did you do this? or did you "copy" it there? That touchscreen - beware of it - is the pi actually booting? What do the Pi LEDS tell you? - but the config for the screen might not be right - is it powered by an external source or usb? Is it ribbon or HDMI? I see you have tried it on a TV as well - is the cable up to it? Finally, you don't say how you are powering the Pi and with what. Is it sufficient? or are you trying to use a phone charger rated at say 1A to run a Pi 3? Lots to consider.


  • I used windisk32 to write the image to the micro sd card. I am using the stock 5V charger that came with the Pi, the red LED is on so it is providing sufficient power. The green LED is blinking. The screen plugs right into the Pi at the GP IO so it rests right on top of the USB and Ethernet ports.


  • @jknudsen97 said in RetroPie will not boot. Blank screen.:

    I am using the stock 5V charger that came with the Pi

    Charger? or Power Supply? What is the current rating? You need 2.5A. Take a look at this. with regard to your blinking green LED as it indicates a corrupt card or an incorrectly written image. One final thing worth a try is that you edit your /boot/config.txtand add or uncomment ( remove the # before ) hdmi_force_hotplug=1. You said that the screen is connected at the GPIO but is it powered externally or by the GPIO or by the USB? - this is why your use of a correct supply is essential. If you are not using an external supply for the screen, you will need to force the hdmi to get the screen to work - I had this issue with a screen that was powered by the usb ports on the Pi.


  • I am experiencing what appears to be a similar issue!
    I followed the READ ME FIRST instructions and confirmed hardware met minimum specs, powercable was sufficient 5V 2.5A. I ordered a new 32gb SanDisk Ultra micro SD HC I, and it has a 10 on it in a small circle, so it appears to be compatible. I purchased a Raspberry Pi 3 model B, so I downloaded the appropriate image from the retropie site (https://github.com/RetroPie/RetroPie-Setup/releases/download/4.3/retropie-4.3-rpi2_rpi3.img.gz) , extracted it onto a folder on my desktop.

    From there I downloaded win32diskimager and used this to mount the image to the card, which took an unexpectedly long time (40 minutes or so), but it was not recognized. by my Pi! That is to say that when I hooked the Pi up to my TV via HDMI cable, and plugged it in, only the Red LED lit up, and there was no green blinking as expected. No error message appeared on screen.

    I formatted the disk afterwards, and tried several times with win32disk imager, being careful to follow the instructions on: https://retropie.org.uk/docs/First-Installation/ . Same result. I watched the video again, but I just didn't get the lights I expected to see. I formatted the device and copied NOOBS onto the card to test the card. My Pi loaded and I was able to get it running. However, as what I really wanted was the Retropie, and am by no means an expert and I did not want to install on top of another OS, so I formatted it again and tried to use etcher and it would not boot.

    I read that this meant the Pi probably can't read the SD card, but I know it worked with NOOBs. Can anyone help?


  • @allfather said in RetroPie will not boot. Blank screen.:

    which took an unexpectedly long time (40 minutes or so)

    Is the card genuine? It takes less than two minutes to write the image.


  • @rbaker
    It should be! I ordered it from amazon. The whole experience has been frustrating, having tried to image the thing a dozen times at 40 minutes a piece. Any my PC isn't slow, I'm running an MSI Apache Pro.


  • Hi all,
    I am having the same problem, when I download the zip file windows has it as a PDF file/Gz file, I am nor sure this is correct, should it be a RAW file?
    not sure if windows is automatically changing this once downloaded?
    any clues?


  • @bucky1970
    The .GZ file is fine, you will need 7zip to extract the file. Once extracted, you have a .img file which you can mount to your SD card with win32diskimager or etcher


  • @allfather
    ok thanks that's worked


  • @bucky1970 Awesome! I'm hoping someone is able to assist with my issue too!


  • @AllFather I don't know if it is still an issue but I know Amazon had a very notorious reputation for allowing fake sd cards through. Also , with a USB 3.0 adapter and matching port, the writing to the card should take almost no time at all. Even on a 2.0 port and older card I know a 32gb image will write in 30 min or less. If it is a good card, perhaps it's a corrupted download or extraction?

    I know last time I had an issue I re-downloaded the image , was forced to manually deleted the partitions on the card, and created news ones. I only use Samsung Evo cards anymore and they have been beyond phenomenal and the price point is perfect.

Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.