Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

Restart/Shutdown/Reboot EmulationStation options do not work after manually compiling ES from source



  • So when I select "Restart EmulationStation", "Restart System", or "Shutdown System" from the EmulationStation "QUIT" menu EmulationStation closes and drops to the terminal with no error messages.
    I manually compiled ES using the following steps:

     git clone https://github.com/RetroPie/EmulationStation
     cd EmulationStation
     git checkout master
     git submodule update --init
     cmake .
     make
     sudo make install
    

    This issue occurs with no changes made to the source code. For some reason when I compile ES through the retropie_setup.sh script it works just fine, but when I manually compile it using the above commands the menu options listed do not function correctly.
    I tried to find the script that compiles emulationstation from source in the retropie_setup.sh script but I couldn't find it (i'm still looking for it). I was thinking I might be able to compare the commands used to compile it with the commands I used and see if there are any differences.

    I'm not sure if this is relevant but I also compiled/installed the following from source before ES was compiled:
    SDL2-2.0.7 from http://libsdl.org/release/
    https://github.com/Pulse-Eight/platform
    https://github.com/Pulse-Eight/libcec/

    Any ideas?


  • administrators

    @madmodder123 you need to use the emulationstation.sh launch script.



  • @buzz Could you please elaborate?
    I know that it is in the EmulationStation source folder, but I am not sure what you mean by using the script.


  • administrators

    @madmodder123 the script handles the rebooting etc. You need to launch the script not the binary directly.



  • @buzz So would I have to place the script in the /usr/bin or the /usr/local/bin folder? I am not sure where ES gets called upon on system boot. After moving the script file would I have to edit another file that directs the OS what to launch upon boot? I am using RetroPie 4.3.7 btw.


  • administrators

    @madmodder123 we have another launch script for /usr/bin that launches the .sh script. This repo is designed to be used with RetroPie not manually installed. For more info on how it's launched check the RetroPie module. Why are you manually building it?



  • @buzz I am changing the on-screen help button icons to ones that resemble the PS1 controller's buttons and changing the ES fonts used. I have them all sorted and then I ran into this issue.

    I'll see if I can get this figured out and i'll report back here



  • @BuZz Thanks for your help

    I got it working, I replaced the /opt/retropie/supplementary/emulationstation/emulationstation file with the one that I compiled myself. I hope this post can help someone in the future :)



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.