Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

Retropie Crash after 3 seconds of Boot up



  • I have had this issue happen to me twice now in the last week.
    I image retropie 4.3 on to my card (after formatting of course) (Windows PC) using Win32DI.
    Everything goes well and boots up normally.
    I then go in and set out to do some configuring.
    Update setup script then update retropie, underlying kernals, download my themes all the stuff we normally do on a fresh image. I add controllers, I set up all emulators, roms w/ vid previews, set theme, get all my bells belled and whistles whistled. Reboot, admire the work and then shut down properly to back up the end result.
    I insert the card, Win32DI again… read, done.
    Insert card back into the Pi, it starts up my TV upon receiving the signal, boot texts for about 3 seconds and dies and "No Signal" turns up on my TV as well as my VGA monitor. After tons of thought on this, is it my pc? My WIn32DI program? Is it the backup process that is bugging the boot up? I examined the card on my pc nothing seems to be wrong in any of the files I even copied them prior to be sure.
    I then said to myself "okay, let me write a 3rd party image and see if that works" It wrote to the card as well as boot up and so far I have had no issue but I have gone this far prior before failure.
    I only updated the setup script this time to see if leaving the underlying kernels the way they are maybe the culprit??? I have tried for the life of me to search for this problem and maybe I have come here a bit prematurely but this has happened on two separate occasions with two different cards. I am sure they are not knockoffs as I checked that as well and they are Evo and Sandisk. I'm a few months into this and I figured this was the best place to come. I have run all the bases I can think of.
    I actually have three Pi 3's and the image would not boot on any of the three. I have built and played with quite a few of them in the last few months and all of them are working fine. I did the same process to each of them. As I said I got this same issue twice in the last week. If I left out any useful info I apologize. Inform me and I will add any info I can think of.
    Its been a few hours no and so far so good. But I have not tried to back the image up. If the Pi boots up in the morning I will try to back it up and see if the same thing happens again.
    Maybe then I will uninstall WIN32DI and reinstall as the issue may be with the program. My pc did have a hard shutdown yesterday during the night but I checked to see if everything was okay and as far as I could tell minus my audio driver got knocked out. I guess the possibility could be that but then again it did this before one other time a week ago. Anything is possible I guess.
    Anyone who has an idea please shoot it at me!
    Pi Model or other hardware: 3B
    Power Supply used: North Pada 5v 3a
    RetroPie Version Used 4.3.7
    Built From: Retropie 4.3 image, Used WIN32DI to image it to the formatted 32gb Samsung EVO msd card
    USB Devices connected: Logitech Chillstream Xbox style, 128gb thumbdrive, keyboard (Also did it without keyboard)
    Controller used: Logitech Chillstream Xbox style
    How to replicate the problem: I am not sure. It happened to me twice now and I believe at this point it is either update related or possibly in WIN32DI during copying of image.



  • Anyone have any light to shed???



  • This morning everything booted up fine. I have uninstalled WIN32DI and I am about to reinstall and copy the image to my PC. I believe the problem may have been caused by the disk imager seeing as how I saw no errors in the corrupted back up image while booting, just boot failure.
    I will report what happens next.



  • Okay before I was even able to back up the card it crashed on me again. At this point I am going to say it is the card but why would it operate all this time with no issue?
    I can not boot fully it goes to boot then it crashes and I have no signal



  • I realize I am talking to myself here but anyway... I am starting to believe the Pi was no good. I have inserted the card in three Pi 3 previously but had no luck booting up. I now tried it in my nespi pi 3 and it booted with no issue other than a usb dev mount failed. I at this point am using this as a running log to keep track but if anyone has any suggestions I would appreciate them.



  • I was talking to someone on one of the pages on Facebook and he was able to replicate my issue. So now I dont think it was the PI so much as I do a bug or something in the setup script. I have booted two other Pi's successfully and I did not update either of them in any way and so far so good.
    Again if anyone has any input I would appreciate it.



  • Are you sure the Pi dies and just didn't lose HDMI connectivity?



  • Yes, are you sure the pi hangs, or if you are merely loosing the display? Can you try to access the pi over ssh using wifi or network cable?



  • Sorry I have been away. Thank you both for the replies. I have been running the Pis with no issue. I do however run them on my VGA monitor as after reviewing everything that had happened I believe it was as you guys suggested, the loss of HDMI majority of the time. Forgive me I have only been doing this a few months and honestly never had an issue on the tv before. My HDMI is ridiculously long as well so I guess that was the culprit. I am now wondering how this guy was able to replicate my issue but who knows if he was telling the truth or not.



  • The length and quality of your HDMI cable could actually have been the culprit, as you said.
    You may want to try with a better/shorter cable.
    Another way could be to boost the HDMI signal by editing config.txt, see here : https://elinux.org/RPiconfig#Video But a good cable is a better solution.



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.