Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

Installed optional binary. Now no emulators load



  • I installed an optional binary on my 4.3 raspberry pi 1, (using sudo ./retropie_setup.sh)
    Now none of the emulators work from emulation station. I select a game. Screen goes blank.
    I see on the console

    ALSA lib pcm.c:7843:(snd_pcm_recover) underrun occurred

    listed a few times down the screen.
    I don't even get to runcommand text window. Attempting the start the game fails and I'm returned to emulationstation.
    All the emulators worked fine before, but now for some reason they are all doing this! Nothing works and I have no idea how to fix it.

    I manually tried executing the emulator binaries from a CLI and they all still work.

    Any idea what I've done, or what's going on?
    Must be some configuration that's been thrown out of whack....



  • @neo-rio Give us a hint. What did you install? This piece of information may somehow be relevant.



  • VICE binary

    There is no log in /tmp or /dev/shm to go on when loading the emulator fails.

    I suspect there must be some general config problem. All the emulator binaries haven't been updated. If I manually execute them from CLI, they will work (e.g. x64 in the case of VICE). Emulation station is just getting hung up.



  • @neo-rio Link to a thread citing similar issues. https://retropie.org.uk/forum/topic/8435/alsa-lib-pcm-c-7843-snd_pcm_recover-underrun-occurred/11
    it seems that a full update may sort the issue.



  • I figured out what the problem is. It all has to do with emulation station, and how much system resources it uses when game directories have huge numbers of ROMs in them.

    Why installing VICE killed it for me.... I added about 25,000 odd C64 games into the directory. Emulation station typically reads through the directory to see how many games are in each systems rom directory. With so many, it was slamming the raspberry pi 1 that I have, and for some reason due to this, none of them emulators would start likely due to the pi running too slow or running out of memory to keep up.

    Then I deleted all games from the c64 rom directory - et voila.... all the emulators are working again.

    Therefor, there must be some way to limit the resources that emulation station chews up. Preferably getting it to stop counting roms in each system directory would be a good start.



  • Also noticed that I don't have to add lots of games. Simply adding more and more systems to retropie will also chew up ES's RAM until it can't launch anything.

    I might try playing around with the memory split to see if this helps at all, and allocating more VRAM to emulation station... but it may not work. Currently I have the memory split at 128.



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.