Please do not post a support request without first reading and following the advice in

DragonRise Inc Generic USB joystick - Y axis

  • Hi,

    Seems that disucssion about 'DragonRise Inc Generic USB joystick' been active about year ago.
    I bought N64 controller and everything else works OK but joystick Y axis is doing the same that pressing D-Pad up and down.

    It's playable but hard to play when the values are max when trying to move peacefully or sneak in the game. :)

    jstest indicated that D-Pad are 0 and 1 and joystick is 2 when moving X direction.
    There's no value for Y at all or there is but it's same that pressing D-Pad up and down (0 and 1).

    I edited controller's config file and now X axis works OK, but Y axis is impossible to get it work because there's no value just for Y, atleast what jstest says.

    Everyone in the internet seems to indicate it's Linux driver issue.

    Any idea is it fixed already and if it is should I do 'rpi-update' or 'apt-get update' etc to get the latest driver?
    I've done update from retropies menu and it not help.

    I saw this but it's 1y ago:

    And some dicussion about the driver in here:

    All help are highly appreciated! :)

  • Global Moderator

    @jura The issue you reference seems solved upstream (Raspbian), are you running a current kernel+firmware ? Run sudo apt-get update && sudo apt-get dist-upgrade to get the lastest kernel and rpi-update to get the lastest firmware.
    You can find your kernel version by running uname -a from a command prompt or a ssh session.

  • @mitu , thanks, that's my plan!
    Just being curious, where did you got that information that it is fixed in Raspian?

    I try to run commands sudo apt-get update && sudo apt-get dist-upgrade.

    I red from forums that running rpi-update is not maybe the wisest idea because it might contain some bugs because not released as stable, maybe that's my last option but I got to make backup before that. :)

  • Global Moderator

    @jura said in DragonRise Inc Generic USB joystick - Y axis:

    Just being curious, where did you got that information that it is fixed in Raspian?

    As I said, from the link you provided -

    Since the reversion is already upstreamed I've backported it to rpi-4.4.y and rpi-4.8.y.

    Current Raspbian (Jessie) I think has kernel 4.9.x, so the fix in the Github issue should be included in the latest kernel in Raspbian. Since you didn't provide any details on how you installed your RetroPie system, I suggested you upgrade your kernel to get the latest version.

  • @mitu , Oh sorry. I apologize.
    Let's try to do some rpi-update and let's see what happens.. :)

  • @mitu, seems that it didn't work with the latest kernel.

    I ran rpi-update command and after that jstest /dev/input/js0 still didn't indicate anything for Y axis.
    Or it did but same values like pressing D-Pad up and down.

    I would like to know is there anything I can do for that controllers joystick setup.
    Seems that when its using udev driver and even updating kernel it wont' help.

    After the kernel update, should I remove controllers config files to make sure it won't use old ones?
    I would imagine that won't affect how jstest is working. :)

  • Wondering should I replace my DragonRise n64 controller by 8BitDo n64 controller because all the issues I have with the current one.
    At least what I understood from forum discussions the 8BitDo is more expensive but also less pain in the butt. :)

  • On my system
    sudo apt update
    sudo apt dist-upgrade

    install kernel 4.9.35-v7+. DragonRise Inc. Generic USB Joystick works without any problem (just redo controller configuration from EmulationStation).

    You should never use rpi-update ;-)

Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.