Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

Tankstick Trackball Not Working in advmame



  • Re: Trackball working in mame4all but not Advmame??

    So after searching this forum I came across an older thread. The Xarcade site says to "Play! The first time you run an Arcade game be sure to choose 'lr-MAME2003' as your permanent emulator for full trackball support" but I am not sure how to do that...

    Wnem I first had this working I saw threads that said the trackball only works in advmame so I installed it and it worked. Retropie showed both. Now I did a fresh install and can not get it to work.



  • @mgrabow Why are you opening a new thread as a reply to the post you cited?

    Trackball works great in AdvanceMAME if you configure it properly, but it has also worked in lr-mame2003 for a long time. It works even better now, due to recent updates. Check the wiki page which walks you through the details.

    Now, the real problem is using a third-party image. As soon as you run into trouble, nobody can help you because none of us know what X-arcade might be doing with their image (over and above just violating the license agreements). They obviously have a configuration they think works with their hardware, but there is no way to know what else could be going on.



  • @caver01 Thanks. the trackball test proved good.

    But there are some assumptions made on the users skill level in the retroarch part...

    *Configuring RetroArch emulators for multi-mouse use

    Input Drivers: As of September 2017, there is only one RetroArch input driver for Linux with support for multi-mouse: udev.
    Determining mice index numbers

    Make sure that your RetroArch input driver is set to udev
    Start a RetroArch emulator with the option --verbose to generate a detailed log. Verbose mode is selected via the runcommand
    The resulting log is saved to /dev/shm/runcommand.log*
    

    make sure it is set to udev? how?

    start retroarch with the option __verbose.. How



  • @mgrabow You can enable verbose logging using the Runcommand. I dunno where you would set UDEV. I have never had to do so. I expect it is the default on a Pi, but RetroPie gets used on other platforms, so perhaps that note is there for folks who might have done something non-standard.



  • @caver01 been googling it.. not sure how to start retroarch using the "runcommand"



  • figured it out....Needed to set the mouse index to "0" in opt/retropie/configs/all/retroarch.cfg

    did this in notepad from winscp.

    cant for the life of me remember how I set to retroarch to run in verbose. I stumbled on a menu for that but cant find it..


  • Global Moderator

    @mgrabow It's in the Runcommand launch menu, see the https://retropie.org.uk/docs/Runcommand/#runcommand-launch-menu page. There is an option called Launch with verbose loggingin the list, choose that option when running the ROM and then check the /dev/shm/runcommand.log from WinSCP while the ROM is running.



  • @mgrabow said in Tankstick Trackball Not Working in advmame:

    @caver01 been googling it.. not sure how to start retroarch using the "runcommand"

    You gotta check the links and read that documentation. See how my reply had Runcommand in blue? I gave you a link to the documentation mitu cited above. I makes no sense for me to explain Runcommand when it is all written better in the documentation.



  • @caver01 I appreciate the help and I did read the link and did not find what I needed.



  • @mgrabow Did you try using Runcommand at launch, and in the menu that appears, enabling verbose mode?



  • @caver01 I had mentioned before that I was able to find it in one of the menus but I cant for the life of me find it again... verbose mode appears no where the link several people have refered be to. I was successful in getting the trackball to work. Now I am just documenting how I did it. I just cant find that launch in verbose mode...



  • @mgrabow It is in the popup menu when you use Runcommand.



  • @mgrabow said in Tankstick Trackball Not Working in advmame:

    verbose mode appears no where the link several people have refered be to.

    The option is in the Runcommand menu, but the screenshot/example of that menu is likely old and does not show that choice as an example. However, if you use Runcommand, L "Launch with verbose logging" is an option.



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.