Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

Help with fixing my sd card!



  • Okay first off let me say that i am not good at this kinda stuff.

    So i think i messed up my micro sd card, for the raspberry pi 3.
    I messed up the my Retropie installion and decided to format my sd and reinstall everything.
    So i did a standard format of it on my windows 10 pc, except i got a little confused cause my sd card reader was showing my sd as two different devices (The last two devices in this pic https://imgur.com/o8RAPcA.
    My initial thought was that maybe i just needed to format both and it would be fixed, obviously that was not the solution and now im kinda stuck here.
    All i want to know is how i can revert them back into the one 32 gb micro sd again.


  • Global Moderator

    @widji Just use Win32DiskImager and write the RetroPie image to the E: partition, then put it back in the Pi.



  • If you just format your card to have the full size available, this is the recommended tool for windows: https://www.sdcard.org/downloads/formatter_4/index.html



  • I wish i could do that mitu it just gives me this error https://imgur.com/bHtuIxx
    I also tried doing it on the F: partition and that gives me the same error.

    EctoOne that doesnt get m anywhere either that gives me an error too and i can still only format the two different partitions.


  • Global Moderator

    @widji Then use the advice given by @EctoOne and format the card first.



  • @widji which version of the tool are you using? The link should be version 5 although it says version 4.
    If it's version 5 you should simply be able to format the sd.
    If it's version 4 you need to change the options to Resize Filesystem or something like that.



  • @widji The way I do it is open the Windows's Disk Manager (by running diskmgmt.msc), and use it to manually exclude all the partitions in the SD Card (on the bottom part of the window there is a helpful diagram showing which partitions belong to which drive, so I right click there on each existing volume on the SD and delete/remove the volumes), once there are no allocated partitions in the drive I right click on the non-allocated volume and create a new volume, and follow the steps on the wizard to create it and format as FAT.

    Then I'm able to use Win32DiskImager to image anything to the SD without problems.

    But be VERY careful to only exclude the partitions on the SD if you choose to do this, you DON'T want to exclude a partition on your hard drive or another connected storage and loose important data or worse.



  • @isrnick I second this method. I don't know what started causing it but after a certain point every card I re-write I have to delete partitions/volumes.



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.