Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

[RetroPie x64] PSX and PS2 games - Core Remap file not loaded?



  • Hello all,

    PSX:
    I tried a game on PSX emulator. Game runs very well but Retropie doesn't seem to load remap core file.
    What did i do? I started the game, then pressed HOTKEY + X to RGUI. On RGUI I selected Controls.
    For User 1 Device Type, i changed from "Retropad" to "Retropad w/ Analog" to use Joystick (otherwise only D-Pad worked to move characters). Then I selected "Save Core Remap File", then Exit, then Resume. Ok... Game works fine and I can play with Joystick.
    Then I stopped game. And restarted it. I could see "Load Core Remap file" during loading but can't use Joystick anymore. Only D-Pad.
    This only way i found to make it works each time, I have to go back to RGUI (by pressing HOTKEY+X), then I have to change something (like go back to "Retropad" then to "Retropad w/ Analog"), then I save Core Remap file and it works.
    If I just start the game, no joystick
    If I select "load Core Remap file", no joystick
    If I re-save "core remap file", no joystick.

    So the only way is to change something (what you want) in RGUI each time your start a PSX game and do a save. Then I can use Joystick, etc... But if I leave the game and start it again or restart Retropie, I should re-do the same thing to get my joystick working, otherwise I only have D-Pad.
    I tried with Game Remap file... same thing
    Is there a solution?

    PS2:
    I installed from package PCSX2. It asked me to downgrade "dont remember what" to make it compatible with x86 (cause x64 wasn't). i said yes.
    I copied BIOS in the right folder, and start a game. Before starting PCSX2 asked me some settings. i did it, included to configure my XBOX one Pad. So i mapped all buttons and D-Pad. But there is no lines for Joystick...
    Well.. I started a game, it works fine too (War of Monsters, we played this game with my sons, years ago) but... no Joystick.
    How can i add Joystick for PS2 games?

    Best regards



  • Nobody got this issue? :/

    EDIT for PCSX2: all is ok. It works fine. Found how to do :D
    EDIT for PSX: can't find anything for this issue. And if tehre are 2 players, i have to do same change for all players, not only for the first one.
    Yet, when game is loading I can see Core remap file loaded. But doesn't use config in this file.



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.