Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

PCSX2 Question



  • Hi,
    I use PCSX2 in Retropie on Ubuntu 16.04 x64. All works fin, very fine.
    Is there a way to install LilyPad plugin to get more than 2 pads (like in the Windows version of PCSX2) or is ther anothere way to get 4 controllers working on PCSX2?

    Best regards



  • Please, I really want 4 controllers working on PCSX2. Someone knows how to do?


  • Global Moderator

    @xboxwin There are no many users of PCSX2 here, but have you tried the PCSX2 official documentation or searching around for guides suites for Ubuntu/Linux ?



  • @mitu (thank you for your reply. I thought nobody cares xD)

    Yes of course. Before asking, I search by myself :D
    I think I read almost all forums/threads about PCSX2 on Linux for 4 controllers.
    Some guys asked, like me, "how to get 4 controllers working on PCSX2 under Linux". But there are no many replies. And when there are, I tested it without success.

    To be sure that PCSX2 supports 4 pads, I tried it on Windows 10... Works fine, even with 4 controllers. PCSX2 for windows uses Lilypad plugin (not Onepad plugin) and by enabling Multitap in Lilypad I suceeded to configure 4 controllers which works perfectly.
    But on Linux, libLilypad has no GUI. Developper (Gregory) never finished his plugin (that's what he said (Here the thread from Gregory) . But maybe libLilypad can work like that. And what i have read about this plugin on Linux is: each time you close PCSX2 (under Linux I mean) you loose all your binds. Not fun if i have to re-bind 4 controllers each time I want to play. I could try but I dont know how to configure it without GUI and I didn't find anything.

    So I kept looking for other solutions.
    And found a thread where another guy asks for 4 pads by using "libOnePad" plugin (libOnePad is the official plugin used in PCSX2 in RetroPie). In this thread, someone offered him to compile another libOnePad which should support 4 pads. here. So I downloaded the file, unziped it and placed it in the right folder for PCSX2. Unfortunately, this plugin is not recognized by PCSX2. I can't see it in the menu where we choose which plugin we want. I even tried to rename it as libonepad-1.1.0 (same name as the one I had) but when PCSX2 loads plugins, it returns an error... bad plugin or something like that.

    My last chance: I sent to my server a file (pcsx2-1.4.0-8-x86_64.pkg.tar.xz) that I will test tonight. Inside there are some plugins (probably same as mine but maybe...)

    So ... yes, I read many many threads, tried many things... but it seems I can't find a solution alone :( (if there is a solution)
    I hoped someone here succeded...



  • Just to give you the end of this search. Not great end :/

    I spoke with Gregory which is the guy who started to port Lilypad plugin from Windows to Linux.
    Infortunately, he won't finish his port. So LilyPad plugin has no GUI and no way to configure it by editing .ini file.
    The 2 other plugins (libOnePad and libPokopom) doesn't support for the moment 4 pads and there is nobody working on it.

    So, except if a great developper from RetroPie find a solution or write a plugin.... Let me hope!

    Well :/
    (FYI, Lilypad works great on Windows with 4 pads connected (Multitap options enabled)).


  • Global Moderator

    Thank you for the follow-up.



  • @mitu I kept looking to find a solution. Yes I know, I'm a bit stubborn :D

    I need help for the following:

    • I found this same link: https://github.com/KrossX/Pokopom/wiki/Pokopom
      So I tried to follow this "topic".

    • I started a Terminal on Ubuntu 16.04 LTS x64 and typed this command: git clone https://github.com/KrossX/Pokopom && cd Pokopom && mkdir build
      All was ok.

    • then I typed: cd build && cmake ..
      and get the foloowing result:
      kasi@kasi-G752Linux:~/Pokopom/build$ cmake ../
      -- Configuring done
      -- Generating done
      -- Build files have been written to: /home/kasi/Pokopom/build

      All was ok.

    • Then, cause I'm under Linux, i typed : make
      And got an error:
      kasi@kasi-G752Linux:~/Pokopom/build$ make
      [ 4%] Building CXX object CMakeFiles/padPokopom.dir/Pokopom/Chankast.cpp.o
      In file included from /usr/include/string.h:25:0,
      from /home/kasi/Pokopom/Pokopom/General.h:29,
      from /home/kasi/Pokopom/Pokopom/Chankast.cpp:5:
      /usr/include/features.h:367:25: fatal error: sys/cdefs.h: Aucun fichier ou dossier de ce type
      compilation terminated.
      CMakeFiles/padPokopom.dir/build.make:62 : la recette pour la cible « CMakeFiles/padPokopom.dir/Pokopom/Chankast.cpp.o » a échouée
      make[2]: *** [CMakeFiles/padPokopom.dir/Pokopom/Chankast.cpp.o] Erreur 1
      CMakeFiles/Makefile2:67 : la recette pour la cible « CMakeFiles/padPokopom.dir/all » a échouée
      make[1]: *** [CMakeFiles/padPokopom.dir/all] Erreur 2
      Makefile:83 : la recette pour la cible « all » a échouée
      make: *** [all] Erreur 2

    • I searched on Google and found a solution. So I typed:
      sudo apt-get install g++-multilib libc6-dev-i386 and got the right libraries for x86.

    • I tried another time the previous make but still got an error. Not the same:
      kasi@kasi-G752Linux:~/Pokopom/build$ make
      [ 4%] Building CXX object CMakeFiles/padPokopom.dir/Pokopom/Chankast.cpp.o
      [ 9%] Building CXX object CMakeFiles/padPokopom.dir/Pokopom/ConfigDialog.cpp.o
      [ 14%] Building CXX object CMakeFiles/padPokopom.dir/Pokopom/DebugStuff.cpp.o
      [ 19%] Building CXX object CMakeFiles/padPokopom.dir/Pokopom/demul.cpp.o
      [ 23%] Building CXX object CMakeFiles/padPokopom.dir/Pokopom/FileIO.cpp.o
      [ 28%] Building CXX object CMakeFiles/padPokopom.dir/Pokopom/Input_Linux.cpp.o
      [ 33%] Building CXX object CMakeFiles/padPokopom.dir/Pokopom/Input_Shared.cpp.o
      [ 38%] Building CXX object CMakeFiles/padPokopom.dir/Pokopom/Input_XInput.cpp.o
      [ 42%] Building CXX object CMakeFiles/padPokopom.dir/Pokopom/playstation_dualshock.cpp.o
      [ 47%] Building CXX object CMakeFiles/padPokopom.dir/Pokopom/playstation_dualshock2.cpp.o
      [ 52%] Building CXX object CMakeFiles/padPokopom.dir/Pokopom/playstation_guitar.cpp.o
      [ 57%] Building CXX object CMakeFiles/padPokopom.dir/Pokopom/playstation_mtap.cpp.o
      [ 61%] Building CXX object CMakeFiles/padPokopom.dir/Pokopom/psemupro.cpp.o
      [ 66%] Building CXX object CMakeFiles/padPokopom.dir/Pokopom/regini.cpp.o
      In file included from /usr/include/c++/5/random:49:0,
      from /usr/include/c++/5/bits/stl_algo.h:66,
      from /usr/include/c++/5/algorithm:62,
      from /home/kasi/Pokopom/Pokopom/regini.cpp:8:
      /usr/include/c++/5/bits/random.h:107:26: error: expected unqualified-id before ‘__int128’
      { typedef unsigned __int128 type; };
      ^
      CMakeFiles/padPokopom.dir/build.make:374 : la recette pour la cible « CMakeFiles/padPokopom.dir/Pokopom/regini.cpp.o » a échouée
      make[2]: *** [CMakeFiles/padPokopom.dir/Pokopom/regini.cpp.o] Erreur 1
      CMakeFiles/Makefile2:67 : la recette pour la cible « CMakeFiles/padPokopom.dir/all » a échouée
      make[1]: *** [CMakeFiles/padPokopom.dir/all] Erreur 2
      Makefile:83 : la recette pour la cible « all » a échouée
      make: *** [all] Erreur 2

    It seems there is something wrong with this "__int128"
    I tried to search what was wrong with Goggle but didn't find anything that I understand.

    Someone could help me?
    or
    Someone who uses Ubuntu 16.04 LTS could try and it's a success, upload libKopokom.so?

    Thank you in advance
    Regards



  • I am trying to get PCSX2 installed on my retropie. Do you mind if I ask where you got the bios files to install it.



  • I got a libPokopom.so which can work but... when I start PCSX2, stop the game and try to change a plugin, each time I press "Apply" or "Validate", PCSX2 crashes. And go back to games list.
    I think it's a problem with PCSX2, not RetroPie.
    So my question is: where is the folder with plugin configuration files? It seems .ini files are not with plugins files.



  • @theravager I dunno if I can give this kind of link but... on Google, just type "PS2 Bios" and the first line will be the good one :D
    if you can't find them, contact me in private i will give you the link


  • administrators

    @xboxwin defeats the purpose of the forum rules. Stop it.



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.