Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

Help - Stuck - SD Card issue?



  • Hello all,

    After looking at the forum and some youtube videos, I cant figure out whats going on.

    OS: Windows 10
    SD Card: Approved SanDisk 128GB Micro SDXC Class 10 - "SDSQUNC-128G-GN6MA"
    Software: WinRar & Etcher
    Raspberry Pi 3

    OK so, i download the Zip file (retropie-4.3-rpi2_rpi3.img) from the Retropie website for raspberry pi 3.

    I extract the file (retropie-4.3-rpi2_rpi3) to my desktop.

    I open Etcher, select the extracted file, select my SD card (H:/) and click flash.
    Upon completion everything looks fine. I look at file explore and see H:/ boot and now newly created I:/.

    I immediately get prompted to format I:/ by windows. I have tried to do it and not do it and I get the same result. A black screen when pulling into my RP3.

    I have to open diskmanagemet and delete the partitions and format to NTFS. I was getting errors doing quick and full formats. But i went into CMD as admin and formatted that way.

    Help I am endless stuck here.


  • administrators

    @hetakuso said in Help - Stuck - SD Card issue?:

    I immediately get prompted to format I:/ by windows

    Ignore that. Windows doesn't know what's it talking about. Just safely eject it at that point and plug it into the pi and it should boot.

    If you're worried about formatting it you can try sdformatter first.

    If it still persists you may have a bum card.



  • OK now i am getting error:

    VFS: unable to mount root FS on unknown block (179,2)


  • Global Moderator

    @hetakuso Re-write the card with the image again, then remove it - and ignore the Windows format messages - and try again.



  • Try formatting the SD card with this formatter specifically written for SD cards. Windows format can sometimes corrupt the card or not format it fully correctly. It does happen, I've had cards that refuses ti work correctly after a windows format and I tried this in the past which worked

    https://www.sdcard.org/downloads/formatter_4/

    This util is a lifesaver as well. Writes a disk image to the SD card and I've used this so solve much head banging when nothing seemed to work and got the same problems you're having. This fixed them as well

    https://sourceforge.net/projects/win32diskimager/

    Install it, and then run it and choose your image and the destination. It also writes to USB drives as well if your creating a boot USB from an image

    Once started leave it alone, it will work it can be a bit slow to start and appears nothings happening

    If that still refuses to work, you might have to try a different brand of SD card. It happens



  • Hello all,

    After all of ur help, I mounted the Image on the SD Card and it worked. I want to thank EVERYONE here for their help and support!



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.