Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

8Bitdo SF30PRO L2, R2, Home and Share buttons not working in ES.



  • Yesterday I assembled and installed my Raspberrypie 3b/Retropie and on 1st installation i connected my 8bitdo SF30PRO without problem via BT and configured it with ALL buttons working. Eventually I had to wipe the installation from my SDcard and redo the whole thing because I messed something up with the name of the Pie (used spaces, which gives problems along the way, even if you change it back).
    After installing the image again and booting the Retropie and ES, I once again connected the 8bitdo SF30PRO over Bluetooth without problem. Only this time I cannot for the life of me get the L2, R2, Home and Share buttons to work during configuration (start, configure controls). I did not do anything different compared to the 1st time around, yet the buttons just wont get recognized.
    I'm pretty newb to the whole thing but yes I have tried both options in the BT menu thats say something along the lines with 8bitdo controllers and i also updated the firmware of the controller itself (yet this couldn't be the problem, cause it was on old firmware when they worked at 1st.

    Anyone got an idea how this is possible and how to fix it?

    Thanks in advance!
    Bogus.


  • administrators

    @bogus which mode did you pair it in? Likely you did one of the modes that doesnt recognise the triggers for some reason. I forget which it is. Mine won't. Even pair but I havent had the time to look into it yet



  • @herb_fargus
    Cant rlly remember, but i think i tried all of them by now. Then again, i dont rlly know when i do or dont switch between modes. Do i have to pair it fresh in BT everytime i want to try a diffrent mode?



  • @herb_fargus

    So yea, this topic helped(see qoute below). Now i connected the controller in start+Y (switch)mode which the pie recognizes as a pro controller and not as 8bitdo controller but enables the triggers (L2 and R2) AND i connected it in start+X (windows or android)mode which makes it recognize as 8bitdo controller but does not enable trigger, it does however enable rumble. Now i can swap between both type of connections just by putting the controller in a different mode. Not optimal, but it'll have to do for now.

    @meats said in 8bitdo SF30 Pro and SN30 Pro:

    This post is to help and kickoff a discussion about the new 8bitdo controllers for Retropie. I spent a couple of hours today getting this configured and I'm hoping this post saves some folks some time and leads to a better understanding of how these controllers work.

    While the 8bitdo website shows support for Raspberry Pi, I actually dont think its as tightly integrated when compared to other systems the controllers claim to support, which are Nintendo Switch, Android, Windows and MacOS. This is very evident when you goto the 8bitdo website and review the product manual. You will only see setup instructions for those 4 systems:

    http://download.8bitdo.com/Manual/Controller/SN30pro+SF30pro/SN30pro+SF30pro_Manual.pdf

    What I found out through the course of testing with RetroPie/RaspberryPi, is that these controllers produce 4 different BlueTooth addresses and different BT names depending on what mode you put the controller in BEFORE you pair them!!!! Maybe other controllers do this and I'm not aware, but I found this very interesting.

    As an example, the following BT addresses were found for the SN30 Pro (aa, bb, cc... are unique to each line)

    • E4:17:D8:20:aa:bb - Setup using Windows (START + X) - Name = 8Bitdo SN30 Pro
    • E4:17:D8:20:cc:dd - Setup using macOS (START + A) - Name = Wireless Controller
    • E4:17:D8:20:ee:ff - Setup using Android (START + B) - Name = 8Bitdo SN30 Pro
    • 98:B6:E9:42:gg:hh - Setup using Switch (START + Y) - Name = Pro Controller

    and the following for the SF30 Pro:

    • E4:17:D8:CF:ii:jj - Setup using Windows (START + X) - Name = 8Bitdo SF30 Pro
    • E4:17:D8:CF:kk:ll - Setup using macOS (START + A) - Name = Wireless Controller
    • E4:17:D8:CF:mm:nn Setup using Android (START + B) - Name = 8Bitdo SF30 Pro
    • 98:B6:E9:42:oo:pp - Setup using Switch (START + Y) - Name = Pro Controller

    When attempting to map the controller buttons using Windows or Android, both the Left and Right triggers were not recognized. The triggers were recognized with Switch and macOS.

    Also, my controllers shipped with firmware version 1.03 and the newest on 8Bitdo's website is 1.10. I would recommend upgrading and paying close attention as the config on these probably shipped half baked.

    In summary, your best bet for RetroPie is to setup the controller using the Switch instructions and dont map the Hotkey button if you want to exit back into emulation station. I would also recommend disabling wifi to reduce any other possible interference on the BT spectrum.

    EDIT: I also performed the udev mapping , but have not tested if that is critical or not for these controllers. Hotkey recommendation is probably my lack of understanding on how that works, so that might not be necessary as mentioned below by others.

    I hope that helps and I hope 8bitdo provides more clear instructions on Raspberry Pi setup in the future.



  • @bogus If you read further down in that thread here you should connect it in android mode.



  • @rion, Big thanks!

    Added that connection as well and strangely enough now it does enable the L2 and R2 buttons. I could swear I've tried start+b (android) before...



  • @bogus Glad you got it solved.



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.