Please do not post a support request without first reading and following the advice in

Can't get 6 button controller Sega emulators.

  • I am using a Raspberry Pi 3 Model B with Retropie 4.3.13, I updated this morning, 03/13/2018. I have 2 wired SNES controllers and 2 wired Xbox 360 controllers all of which are mapped correctly and work in every other emulator just fine. I can't get the 6 button controller setup to work in any Sega emulator, picodrive or genesis-plus-gx. I have tried all the options from the Git Hub setup pages for Megadrive, 32x, and Sega CD, which are all the same. The core map saved the input setting to 6 button in the RGUI in both emulators but still lets me use just 3 buttons and the start button. Then I reversed that by deleting the remap files and trying to put the manual 6 button control settings in the respective retroarch.cfg folders. I got that done, saved, restarted, and still no 6 buttons. It actually say 6 button in RGUI but I can only use ABC(Y) and start. Please point me to what I'm doing wrong. If there's an answer out there I haven't found it. Thanks.

  • @bharper not all games took advantage of 6 button controllers. Also some games have a setting in game that you need to switch to 6 button controller, Mortal Kombat II for example.

  • I didn't see any settings for changing to 6 button in game. I did try a game called Primal Rage Sega 32x which had a setting to reconfigure buttons in game. I tried swapping them all around, every key had an assigned function and still only getting to use the ABC. So I will look over Mortal Kombat II again but I think there may be more to it. Thanks.

  • @bharper what games specifically are you trying to work with 6 button layout? And which emulator? 32x I am assuming picodrive. You are having an issue with megadrive games using genesisplusgx too?

  • @quicksilver I am not getting 6 button in either emulator. Mortal Kombat II, Primal Rage(which showed 6 buttons used in game), and Street Fighter are some that utilize 6 button layout I've tried. I'm willing to try any game you recommend for setting this, I have most if not all for Sega systems. I haven't had a chance to try Mortal Kombat II to check the "in game" options yet. I have all the 6 button retroarch configurations correct, I used SSH from work to confirm that I had the correct entries in the correct retroarch.cfg/retroarch-core.cfg, and they were. I will try Mortal Kombat II when I get home this evening and let you know. With Primal Rage not working even though it showed 6 buttons used in the "in game" options and I had 6 button engaged for both emulators. I feel like I'm missing something small as the RGUI shoes me using 6 button on both inputs. Thanks again for helping out.

  • @quicksilver I tried both picodrive and genesis-plus-gx in Megadrive/Genesis and in Sega CD. My only emulator option for 32x is the picodrive. All the games run fine, just not all the buttons.

  • @quicksilver I have 6 button setup working on both emulators as of now. I found the settings you mentioned in Mortal Kombat II but changing them made no difference. I went over everything on my setup and was stumped. I booted up a fresh image, completely up to date, configured my SNES and Xbox controllers and put on my Sega games only. I made the changes to the respective config files and presto it works. After changing the setting you pointed out that I missed earlier in Mortal Kombat. I don't know why my original setup was not working. It has to be something I modified but I haven't found it. Thanks for you help and if I track it down I'll let you know.

    Update: I think I found the problem. When I updated in the morning I did both binary and source, I've never used source before. It wrecked my controller configurations. It had my generic SNES listed as generic and just SNES, and the Xbox controllers were listed as generic Xbox, the original config, and Xbox 360 Pro. Every game I launched listed the two controllers I had connected twice and then worked in piece. Not sure why updating from source would do this as I have updated from binary and it was fine. In the future I will probably unplug all controllers and use the keyboard for updating.

Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.