Please do not post a support request without first reading and following the advice in

keyboard defaults to player one, logitech to player two and I cannot access RGUI menu. LR-psxrearmed

  • Mac mini running x86 ubuntu
    retropie 4.4
    Built from retropie website
    Logitech dual action, logitech f710, wireless keyboard and mouse using one 2.4 dongle

    I have this issue with lr-psxrearmed but now have it in lr-fceum too from extensive troubleshooting. I will post my retroarch.cfg from the psx core hoping that the solution will fix both cores. As a side note, the logitech dual action was defaulted to player one and the f710 was set to player two but I went into retroarch and switched it because I prefer the wireless f710.

    I have no idea how I caused this problem. I was playing psx on my retropie about a week ago then went out of town for a week. When I tried to open a game last saturday the player one controller defaulted to the keyboard and the player two defaulted to the logitech dual action controller.

    The only keys that work on the keyboard are the ones required to play the game. The escape, hotkeys, ect all do not work and I have to hit the windows button and exit out of the command window to exit the emulator/game. On the dual action controller everything required to play a game also works. I can play as player two in fighting games and in the raiden project but I cannot hit my hotkey combination to open up the RGUI menu.

    Here are some trouble shooting steps I took:

    • Went into retroarch and tried to switch the f710 to player one and the dual action to player two. This configuration is saved in retroarch but does not fix the issue in lr-psxrearmed.

    • Went into the configuration editor and edited the order of the controllers for both all systems and lr-psxrearmed. Does not change anything. If I set the f710 to player two then I can use the f710 as the player two controller instead of the dual action but I still cannot access the RGUI menu.

    • Went into the configuration editor for just the psx core. I have the same result as above.

    • Downloaded this program to rearrange the gamepad order. Nothing is affected within the psx core and I think this is where I messed up the NES emulator core as well.

    Here is my lr-psxrearmed retroarch.cfg

  • Global Moderator

    @dox1842 Can you try disconnecting both devices, then connect the gamepad first, then the keyboard. See which is player 1 when you start a game with the PS1 emulator core.

  • @mitu I tried this and get the same result. I should have posted it along with my other troubleshooting attempts. I will try it again when I get home but from what I remember it still puts the keyboard as player one and the dual action as player 2.

  • @mitu the dual action is port 0 and the f710 is port 1. Is there a way to enable RGUI access for all players? I have the all_users_control menu set to true but I cannot acess the rgui with other controllers besides player one. Here is one thing that baffles me. If the keyboard is set to player one then why can't I access the RGUI menu? I have hot keys set up for the keyboard.

  • Global Moderator

    @dox1842 said in keyboard defaults to player one, logitech to player two and I cannot access RGUI menu. LR-psxrearmed:

    all_users_control menu

    I think this setting is bugged and doesn't work in RA, despite the name. Does it work with only the controller connected ?

  • @mitu yes it only works on one controller. I just got this fixed!! Thankyou for your help.

    So what I did was I went into the retroarch menu and changed the menu toggle option from "none" to "select + start". By doing this I could hit shift and enter on the keyboard to bring up the RGUI menu and change the configurations back to what I had them.

    Now this is the strange part. On lr-fceummm the f710 was set to player one but the key binds were for the keyboard so I had to reset the binds for the gamepad. On the psx emulator everything was still in place except player one's input was set to "disabled". This is despite what I changed in the config files.

    I am glad I found the solution as I had this problem before except it was with all the emulators. I spent countless hours troubleshooting only to give up and do a fresh install. I god to honest have no idea as to how this happened. I have noticed other post where gamepad order gets switched around.

  • Global Moderator

    @dox1842 I would recommend against editing configuration files directly and using the RetroArch GUI (well, when you can start it) to perform any re-configuration, followed by saving the config 'Per Core' or 'Per Game', see RetroArch-Configuration.
    Glad you got it fixed, enjoy playing !

  • @mitu good look fam.

Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.