Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

Raspberry Pi ridiculously slow when splashscreen service is enabled



  • On a stock Retropie 4.4, when enabling the splashscreen service (via retropie_setup.sh), starting from the next boot the RPi becomes unbearably slow. The splashscreen video plays at about 1/4 speed and takes minutes to boot. When the video is finished and finally boots into EmulationStation, performance is still to a crawl (also in-game, emulators run at 5-15 fps). It remains like this until I disable the splashscreen altogether.

    Tried it on a Raspberry Pi Zero and a Raspberry Pi 1.
    Also tried fresh install and, updated everything (except kernel packages etc)
    I use composite output
    I use PWM audio in the RPi Zero configuration.
    Both cmdline.txt and config.txt are stock (except pwm audio int the rpi zero config).
    Tried powering up from battery, usb 2A PSU, and a bench PSU (3A)

    When the service is disabled and the Pi runs normally, if I manually launch omxplayer with my splashscreen it plays flawlessly.

    What could be causing this?

    I remember vivdly having no problems in these exact machines in the past using older retropie distros and splashscreen videos.


  • Global Moderator

    @danik Seems similar to https://retropie.org.uk/forum/topic/17107/bug-solved-omxplayer-on-stretch-based-builds-stutters-on-composite, reported at https://github.com/popcornmix/omxplayer/issues/625. Try adding audio_pwm_mode=0 to /boot/config.txt and see if it makes a difference.



  • Thanks! That solved the issue!



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.