Please do not post a support request without first reading and following the advice in

High chance of gray/black screen when launching any NES game

  • Hey.

    I'm trying out RetroPie on an Intel Compute Stick powered by Xubuntu 18.04. RetroPie installed gracefully, but I have an issue with games. Most of the time when I try to launch any game (tried NES and SNES games), the screen freezes, shows a gray (or black) screen and a yellow text on bottom left mentioning my controller. Sometimes I can hear the sound playing, and even the game reacting to my inputs, but I cannot see a thing. I can't even close the program in any other way than rebooting (I didn't try, but switching to another tty and killing appropriate processes with pkill could probably also work).
    There also is a small chance that the game will actually launch properly. Changing the driver to vulkan seems to have helped only a little bit, the issue still happens.

    How do I fix this?

    Pi Model or other hardware: Intel Compute Stick STK1AW32SC (x86-64)
    Power Supply used: n/a
    RetroPie Version Used: 4.4
    Built From: RetroPie-Setup script ( on top of Xubuntu 18.04
    USB Devices connected: Wi-Fi dongle, USB hub (connected devices: wireless keyboard, Xbox One controller)
    Controller used: Xbox One Controller
    Error messages received: n/a
    Log found in /dev/shm/runcommand.log: n/a
    Guide used:
    File: n/a (happens with any file)
    Emulator: n/a (every emulator seems to do this - lc-fceumm, lc-nestopia, lc-snes9x...)
    Attachment of config files: no changes made to configs (except for vulkan driver ofc), should I still attach them?
    How to replicate the problem: Try to launch any game from the library.

  • Global Moderator

    Are you sure your setup has Vulkan driver support ? Run RetroArch with verbose logging through the Runcommand launch menu and paste the output of /dev/shm/runcommand.log on to take a look at it.
    Try switching the video driver to sdl2 or x11 and see if that makes a difference.

  • I'm pretty sure it has Vulkan support, vulkaninfo says loud and clear it's supported, and the vulkan-smoketest demo seems to work fine.
    I switched to sdl2 and surprisingly it seems to work stable now! Although I'm hearing/seeing some occasional stuttering even in NES games, could that be because of that driver? Because if so, I'd love to find a way to fix OpenGL and/or Vulkan then.
    I managed to get the runcommand.log file right after the emulator hung, here are the contents:

  • Global Moderator

    @kamild1996 The log file you provided does not have verbose logging. You should enable it to reproduce the problem, then upload the file again. You could post also in the forums to see if they could find the problem, they would probably figure out faster than here.
    I would be interested to know how this would be solved, since 18.04 seems to have a default configuration that's not working with RetroPie, for whatever reason.

  • @mitu Ah sorry, I'll enable verbose logging and I'll reproduce the issue tomorrow :)
    And I'll repost the issue over there, thanks for the advice!

  • Logs, verbose this time :)

    Any other log somewhere in the system that I could attach maybe?

  • Global Moderator

    @kamild1996 There is a similar thread on the RetroArch forums - - with a user having similar symptoms and quite a similar log file. Can you see if modifying the Xorg driver settings - as indicated in the topic - would make your configuration work ?

  • @mitu Doesn't seem like it helped, sadly. Added the conf file to /usr/share/X11/Xorg.conf.d/, after reboot the same issue.

  • Global Moderator

    @kamild1996 There's no obvious error in your log file, so I'm stumped for why it's not working. You should report it on the libretro forums, I think they might have a better chance of finding the problem.

  • You might have to update your emulator or your nes emulator is too powerful for your raspberry pi jk

  • I've read about Wayland fixing things, and it seems like it fixed the issue in my case. Installed KDE, enabled Wayland and it seems to work great now :)

Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.