Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

  • Getting error... Pi3B+ retropie 4.4 wont boot, funny thing is after writing the image it will boot on first power up. But after I cut power I get this error. (not using safe shutdown)
    Any way to fix file system while I can get in on that first boot, is there a fdisk utility I can use? Trying to avoid rebuilding this image...

    [ 216.028173] EXT4-fs error (device mcblk0p2): ext_mb_generate_buddy:756: group 16, block bitmap and bg descriptor inconsistent: 6819 vs 6893 free clusters.

  • Global Moderator

    @drewjbx fdisk only partitions the disk, you need fsck to fix a filesystem. Run fsck.ext4 /dev/mmcblk0p2 to fix the errors, hopefully your sd card is not corrupted.


  • @mitu I used that command via putty and get r/w access...

    fsck.ext4: Permission denied while trying to open /dev/mmcblk0p2
    You must have r/w access to the filesystem or be root

  • Global Moderator

    @drewjbx The command requires root access, so prefix it with sudo:

    sudo fsck.ext4 /dev/mmcblk0p2
    

  • not working for me... mounting / unmounting issue?

    pi@retropie:~ $ sudo fsck.ext4 /dev/mmcblk0p2
    e2fsck 1.43.4 (31-Jan-2017)
    /dev/mmcblk0p2 is mounted.
    e2fsck: Cannot continue, aborting.

  • Global Moderator

    @drewjbx Since the system has booted, I think the error has been already fixed on reboot, but you can still check if any errors are detected with

    sudo fsck.ext4 -n /dev/mmcblk0p2
    

    Don't pull the plug on the PI to shutdown, it's not safe and it might damage your card or the filesystem on it. Just power it off from the Emulationstation menu when you want to shut it down.


  • @mitu said in EXT4-fs error:

    sudo fsck.ext4 -n /dev/mmcblk0p2

    ok so the scan is showing errors, read-only so it cant be fixed correct?

    small snippet of errors -

    Inode 7835, i_blocks is 1904, should be 112. Fix? no
    Inode 103098, i_blocks is 280, should be 288. Fix? no
    Inode 180736, i_blocks is 1344, should be 1400. Fix? no
    Inode 183690, i_blocks is 56, should be 64. Fix? no
    Inode 183692, i_blocks is 1296, should be 1352. Fix? no
    Inode 203483, i_blocks is 1224, should be 1264. Fix? no
    Block bitmap differences: +(547191--547195) +(553503--553509) -(1305697--1305933) -1350145 +1930753
    Fix? no
    Free blocks count wrong for group #2 (1111, counted=1110).
    Fix? no
    Free blocks count wrong for group #15 (8191, counted=8184).
    Fix? no
    Free blocks count wrong for group #39 (3506, counted=3493).
    Fix? no
    Free blocks count wrong for group #42 (6044, counted=7099).
    Fix? no
    Free blocks count wrong (3080458, counted=3094270).
    Fix? no
    Inode bitmap differences: -4110 -7910
    Fix? no
    Free inodes count wrong for group #22 (6190, counted=6218).
    Fix? no
    Free inodes count wrong (7479984, counted=7480006).
    Fix? no

    retropie: ********** WARNING: Filesystem still has errors **********
    retropie: 266000/7745984 files (0.1% non-contiguous), 28121078/31201536 blocks

  • Global Moderator

    @drewjbx Then you'll have to boot your PI in safe mode and fix the errors withfsck.ext4 without giving it the read-only flag.
    Instruction on how to boot into safe mode - https://raspberrypi.stackexchange.com/questions/61638/how-do-i-start-up-in-safemode


  • @mitu So I tried this but couldn't boot into safe mode... no terminal available. Will have to rebuild the image. Thanks for the help, good for future reference.


  • I got the same error message, I fixed it by changing the power supply :/

Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.