Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

start button exits emulators in lr-picodrive and lr-genesisplus



  • Mac mini running ubuntu 18.04 LTS
    Retropie x86 4.4
    Installed through terminal via retropie website
    Logitech dual action
    Logitech f710
    wireless keyboard and mouse with one 2.4gz dongle

    A new week brings a new problem. This started when I downloaded lr-genesis plus just to test out with lethal enforcers. I was playing around with the lightgun emulation to see if i can use the mouse as the light gun. Next thing you know the start button is wired to the "escape" hotkey and the B button is wired to "reset". I have seen others with issues in this forum but no solutions. This issue persist with both LR emulators.

    Here is my cnfg file:

    input_exit_emulator = "escape"
    input_exit_emulator_btn = "nul"
    input_exit_emulator_axis = "nul"
    input_exit_emulator_mbtn = "nul"
    input_state_slot_increase = "f7"
    input_state_slot_increase_btn = "nul"
    input_state_slot_increase_axis = "nul"
    input_state_slot_increase_mbtn = "nul"
    input_state_slot_decrease = "f6"
    input_state_slot_decrease_btn = "nul"
    input_state_slot_decrease_axis = "nul"
    input_state_slot_decrease_mbtn = "nul"
    input_rewind = "r"
    input_rewind_btn = "nul"
    input_rewind_axis = "nul"
    input_rewind_mbtn = "nul"
    input_movie_record_toggle = "o"
    input_movie_record_toggle_btn = "nul"
    input_movie_record_toggle_axis = "nul"
    input_movie_record_toggle_mbtn = "nul"
    input_pause_toggle = "p"
    input_pause_toggle_btn = "nul"
    input_pause_toggle_axis = "nul"
    input_pause_toggle_mbtn = "nul"
    input_frame_advance = "k"
    input_frame_advance_btn = "nul"
    input_frame_advance_axis = "nul"
    input_frame_advance_mbtn = "nul"
    input_reset = "h"
    input_reset_btn = "nul"
    input_reset_axis = "nul"
    input_reset_mbtn = "nul"

    Notice how escape is bound to a keyboard function but not the controller?? I am really confused by this. Is there a different config file I need to edit?

    • I tried remapping all the keys to something else, like a shoulder button but I still get the same result.

    *I deleted my cfg file and still get the same result.


  • Global Moderator

    @dox1842

    Do you happen to have 'save on exit' enabled in RetroArch?



  • @mediamogul yes I have it enabled.


  • Global Moderator

    @dox1842

    Then you're rogue settings can likely be found in the config file at /opt/retropie/configs/megadrive/retroarch.cfg. With the way RetroPie is set up, the 'save on exit' setting will end up saving a full configuration to the retroarch.cfg file in the system config folder of whatever system you happen to be using when you make a change in settings. This will of course lead to all the systems eventually having settings that don't match each other. It's a feature we don't recommend enabling, but If it's something you really want to continue using, you can mitigate the problems by only changing settings when RetroArch is opened from the 'RetroPie' menu of Emulation Station. This way, the settings will be saved to the master config file at /opt/retropie/configs/all/retroarch.cfg and not those belonging to the various systems.



  • @mediamogul The config filee I posted is from /opt/retropie/configs/megadrive/retroarch.cfg. Thats what is confusing me.


  • Global Moderator

    @dox1842

    Then alternatively, try looking in /opt/retropie/configs/all/retroarch.cfg. Of course, neither should be overriding the RetroArch auto configuration of your controller, so you'll want to make sure 'input_autodetect_enable' is set to 'true'. Also, if you want to return /opt/retropie/configs/megadrive/retroarch.cfg to it's default state, paste the following into it.

    # Settings made here will only override settings in the global retroarch.cfg if placed above the #include line
    
    input_remapping_directory = "/opt/retropie/configs/megadrive/"
    
    #include "/opt/retropie/configs/all/retroarch.cfg"
    
    


  • @mediamogul

    So I went in and modified the config file for my controller and got it working. I just unassigned the hotkeys.

    The problem here though is that the hotkeys work without me pressing the "activate hotkeys" button. In other emulators this feature is kind of nice - ill admit I never used it before until just now to test it out but being able to hold down the hotkey button and exit an emulator or reset the console instead of going into the menu to do it is nice. Here is the question - Why is the "hotkey always on" behavior only prevalent in the megadrive/genesis emulators and not the other LR emulators??


  • Global Moderator

    @dox1842 said in start button exits emulators in lr-picodrive and lr-genesisplus:

    Why is the "hotkey always on" behavior only prevalent in the megadrive/genesis emulators and not the other LR emulators?

    It's not, it's something you probably (mis) configured just for those systems.



  • @mitu How can I reconfigure it for the systems?? I looked on google and there is supposedly a "hotkeys always on" feature but I cannot find it in retroarch nor find it in the setup script.


  • Global Moderator

    @dox1842 Can't say I heard about this 'hotkeys always on' feature - do you have any references ?



  • lHere is someone with the exact same issue as me. Here is a post with the exact same problem and the solution of "hotkeys always on" is on the bottom.


  • Global Moderator

    @dox1842 1st post seems like a hw problem and the 2nd one looks like an wrong hotkey configuration, but nothing about a particular setting in RA. Sorry, I though you were searching for a setting to have 'hotkey always on' in RetroArch and I thought your found a reference to such setting existed, because I haven't heard about it.


  • Global Moderator

    @mitu said in start button exits emulators in lr-picodrive and lr-genesisplus:

    Can't say I heard about this 'hotkeys always on' feature - do you have any references ?

    This particular issue is confusing, as it actually seems somewhat backwards in concept. By not having any hotkey button defined, all the assigned emulator functions will activate without a modifier. Since, again in concept, most people see a button-activated function as a being a hotkey, rather than there being a lack of one, everything gets lost in translation.

    Somehow or another through the activation of 'save on exit' there's a config file overriding the assigned hotkey of the automatic joystick config and the start button is being allowed to exit RetroArch without having a modifier. Straightening the whole thing out is another matter, as I'm not sure how extensively everything is messed up now. I would recommend that @dox1842 first disable 'save on exit' and then go back setting each of the retroarch.cfg files to their default state.



  • @mediamogul how do I set each of the retroarch.cfg files to their default state? I deleted my retroarch.cfg file for the genesis/megadrive and had it recreated and still had the same issue.


  • Global Moderator

    @dox1842

    There should be a default config backup in each of the respective folders that you can copy and past from. The main config can be found at /opt/retropie/configs/all/ and the individual system configs at /opt/retropie/configs/system-name/.



  • @mediamogul What gets me is I have the hotkey defined as button 10> that's the left analog stick on the Logitech controller. The CFG for genesis has this in it so im assuming the button is defined. I am at work now but ill check out the "backups" when I get home



  • @mediamogul I just reset the all config along with the snes and genesis config to default settings. The problem still exists with sega but also now with snes. I am pulling my hair out now!! Any ideas?



  • @mediamogul @mitu Ok I found the solution. If you read the second link I posted , what the guy was saying is that even though the auto assign hotkey was 10 I had to reconfigure it to 10 again under the retroarch settings.

    I am baffled by how this works but it does work so im happy now!! Thanks for your help.


  • Global Moderator

    @dox1842

    I'm glad it's working and the resolution is expected behavior, but keep in mind that this only fixes the singular hotkey issue. While that's a positive for now, as long as you have 'save on exit' enabled and you continue to change your settings further, each system will have different configuration settings and problems like the one you just solved will begin to surface in other areas.



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.