Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

I got rid of Ghosts Inputs



  • Hi,

    I managed to get completely rid of ghosts inputs and wanted to share my solution, so maybe it can help somebody.

    I had 2 controllers paired with retropie on the onboard BT, a PS4 V1 controller and an 8bitdo. Both had the ghost inputs problem in menus.
    Maybe some steps are unecessary; feel free to comment, i'll edit the post if it's wrong.


    raspberry switched off.

    plug an usb keyboard.

    Launch retropie

    go to the bluetooth settings, and unpair everything.

    reboot properly.

    Once rebooted, exit emulationstation.

    with SSL edit config.txt with command line sudo "nano /boot/config.txt"

    add "dtoverlay=pi3-disable-bt" at the end. Save and Exit properly. Maybe reboot and check the line is still present after reboot to be sure.

    Shutdown everything.

    Get an UBS BT 4.0 plug and play dongle, plug it.

    Switch on retropie and emulationstation.

    Make sure controller are charged.

    Pair again your controllers using the keyboard.

    Reboot properly.

    Emulationstation should propose you to configure the controller, do it.


    Should be ok ! with no ghosts inputs, and a little less lag, depending on the usb dongle quality.

    Edit : once paired, my controllers are only used by retropie. Dont expect to be able to use it alternatively with retropie and PS4, or you'll have to re-pair them again.

    Edit 2 : if you use ethernet and don't need WIFI, you can also add dtoverlay=pi3-disable-wifi to the config.txt file, some say it lowers latency.



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.