Please do not post a support request without first reading and following the advice in

Can't Transfer ROMS via USB

  • Hi,
    I followed the instructions here:
    But it still doesn't work. The USB never stops blinking. I also tried putting the files/roms on the USB manually since I already had them because I have gotten it to work previously, and that didn't work either. I'd love it if anyone has any tips.


    Edit: I'd also like to add that I'm using a Rpi 0, which is why I would really like to avoid transferring ROMs over wi-fi at all cost, since plugging in a usb stick is infinitely more convenient than connecting the Pi to wi-fi via ethernet. And yes, I have tried burning a new RetroPie image onto the micro-sd.

  • @louwess After you inserted the FAT32 formatted USB into the Pi and then inserted it to your computer, were all of the rom folders created automatically before you copied roms over to the auto created directories? Such as placing the NES rooms in the NES folder?

  • No, the USB blinks forever and eventually I think that there's no way it isn't done so I pull it out but there isn't anything in the retropie folder. So I put in my own folders which I had from a separate instance where the USB transfer had been successful, put the ROMs in their respective folders, put in in the Pi, restarted Emulationstation, and still nothing.

  • @louwess did you enable the USB rom service and make sure the folder is all lowercase?

  • Global Moderator

    @louwess The Pi Zero is finicky about USB hubs - how are you connecting your USB stick to the Pi ? Do you have a keyboard to exit ES and run a few diagnose commands ?

  • Well, I'm actually using an otg adapter that is soldered to a regular female USB port cause I'm making a portable thing from Adafruit. (Details here: But I checked each solder point, so that isn't the issue. I do have a keyboard, what commands do you recommend running?

  • Global Moderator

    @louwess Exit ES, then run dmesg -c to clear the kernel message log. Insert the USB stick and leave it for a few seconds, then run dmesg and look at the message log to see if the stick is detected.
    EDIT: Make sure the usbromservice is installed and running (ps -ef | grep usbromservice).

  • Hmm, I tried to plug in the keyboard but it doesn't seem to be working either, looks like it is the USB connection that's bugging out. Not sure what could be causing this, since none of the wires are shorting with each other, but I'll ask about it on the Adafruit forums. Thanks everyone for your suggestions!

Log in to reply

Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.