Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

[Solved] Error Updating Driver Package - xpad - xpad patch retropie.diff failed to apply



  • Pi Model or other hardware: Raspberry Pi 3B
    Power Supply used: Official Raspberry Pi Universal Power Supply
    RetroPie Version Used: 4.4
    Built From: Pre-made SD Image on RetroPie website.
    USB Devices connected: Logitech F310
    Controller used: Logitech F310
    Error messages received: xpad patch retropie.diff failed to apply
    File: /opt/retropie/supplementary/xpad/xpad.c

    Contents of Log:

    Log started at: Sat Jun 23 05:18:45 UTC 2018
    
    RetroPie-Setup version: 4.4.1 (c6cebd1a)
    System: Linux retropie 4.14.34-v7+ #1110 SMP Mon Apr 16 15:18:51 BST 2018 armv7l GNU/Linux
    
    = = = = = = = = = = = = = = = = = = = = =
    Installing dependencies for 'xpad' : Updated Xpad Linux Kernel driver
    = = = = = = = = = = = = = = = = = = = = =
    
    /home/pi/RetroPie-Setup/tmp/build/xpad /home/pi
    
    = = = = = = = = = = = = = = = = = = = = =
    Getting sources for 'xpad' : Updated Xpad Linux Kernel driver
    = = = = = = = = = = = = = = = = = = = = =
    
    git clone --recursive --depth 1 "https://github.com/paroj/xpad.git" "/opt/retropie/supplementary/xpad"
    Cloning into '/opt/retropie/supplementary/xpad'...
    patching file xpad.c
    Hunk #1 FAILED at 89.
    Hunk #2 succeeded at 1779 (offset 31 lines).
    1 out of 2 hunks FAILED -- saving rejects to file xpad.c.rej
    /home/pi
    xpad patch retropie.diff failed to apply
    
    Log ended at: Sat Jun 23 05:18:46 UTC 2018
    Total running time: 0 hours, 0 mins, 1 secs
    

    Contents of xpad.c.rej:

    --- xpad.c
    +++ xpad.c
    @@ -89,6 +89,8 @@
     
     #define XPAD_PKT_LEN 64
     
    +#define CONFIG_JOYSTICK_XPAD_LEDS 1
    +
     /* xbox d-pads should map to buttons, as is required for DDR pads
        but we map them to axes when possible to simplify things */
     #define MAP_DPAD_TO_BUTTONS		(1 << 0)
    

    How to replicate the problem: Try updating xpad driver?


    This initially occurred during a full RetroPie Setup update that included kernel and OS updates.

    As you could probably guess, all controls no longer work in all emulators because of this error, though I can navigate EmulationStation (limitly on xinput devices) and RetroPie Setup.

    I have tried uninstalling and reinstalling the xpad driver with the same error above occuring. I have also tried removing the Logitech F310 and using a Buffalo SNES-Style USB Controller, which produced the same results when uninstalling and reinstalling the xpad driver.

    I can restore from the backup image I made before updating, but was hoping it wouldn't come to that.

    Thank you for your time.



  • I can confirm that I have this error even on a fresh install of retropie.


  • administrators

    I will look into it later today



  • @buzz I have the same error and need it to update so I could use one of my controllers, so please do when you get a chance thanks



  • do we need to update the xpad driver? or is it a other problem? ive tried doing this https://github.com/paroj/xpad but still the controller i want to work doesnt


  • administrators

    @cynital you need to wait until I have fixed the patchset.



  • @buzz when you do the patch set do i update it? and i dont mean to be rude or rush you but will it take a while?


  • administrators

    @cynital I just fixed it, but replies like yours are not helpful and if you don't want to come across rude, you might do better to have a little patience.

    the xpad patchset is updated and xpad should now build fine. You need to update the retropie-setup script first.



  • @buzz ok sorry...



  • @buzz sorry to msg you again but updated it, installed x pad no problem, restarted the system but still it doesnt want to configure when i press a, i made sure the controller was supported https://github.com/paroj/xpad/blob/master/xpad.c


  • administrators

    @cynital that sounds like an unrelated issue. Please open a new topic and provide system info etc.



  • @buzz Just updated and no errors occurred. Thank you.

    Edit: Well... EmulationStation is working fine, but RetroArch isn't working correctly with xInput controllers. I'll do some tinkering, then report back if I find a fix or need further help.

    Edit 2: Just decided to restore from backup.

    Edit 3: Yeah, it looks like there is still a problem with xpad. Redoing the update on my backup caused the same issues with RetroArch not working correctly with xInput controllers.



  • Thank you @BuZz
    The problem has been resolved. The update went as smooth as it is expected.



  • @eckaji Fully agree. Tried the same. I have posted since right after the initial 4.4 release, if you use the xpad driver (I use a wireless Xbox 360 controller) and update your OS packages, it will completely break your retroarch controller config (emulation station works fine). Restoring from backup myself! If this is ever fixed let me know! But it's been broken since the 4.4 release, so I don't have high hopes of it ever getting fixed. :(

    EDIT: I just updated retropie setup script and did an update WITHOUT the OS. It STILL broke my xbox 360 controller. Seems like something is still not quite right.

    EDIT 2: I uninstalled XPAD and installed XBOXDRV. That seems to work. Something about the current XPAD driver is breaking in retropie 4.4.



  • Just wanted to confirm wht @jasonw said above

    Same config

    • Raspi 3B+
    • Retropie 4.4 "out of the box" (freshly installed) wth a SINGLE game (joust)
    • Xbox 360 wireless broken (cannot use hotkey, amongst other things)

    I'll try to revert to 4.4 without updating.
    Also once uninstalled, it's impossible to install xpad driver ever again (it says error on diff patch)

    I'lll try going back to xboxdrv too


  • Global Moderator

    @sebulba the xpad driver problem has been addressed for quite some time. Update your RetroPie script first and then re-install the xpad driver.



  • I'll try again :)



  • Updating retropie simply killed the entire retroarch (es doesn't even startup anymore )

    As I know forum like this consider new users as idiots whatever their background might be, I won't spend time arguing.

    Retropie4.4 's support of Xbox 360 controllers is broken. Trying to fix it kills Retropie.


  • Global Moderator

    @sebulba said in [Solved] Error Updating Driver Package - xpad - xpad patch retropie.diff failed to apply:

    Retropie4.4 's support of Xbox 360 controllers is broken. Trying to fix it kills Retropie.

    No, its not. Of course, you can argue that the update 'it killed RetroPie', but that's not what other users have experienced. You probably have other problems with your installation.


  • administrators

    Retropie4.4 's support of Xbox 360 controllers is broken

    Xpad works just fine. Xboxdrv has known issues with multiple controllers but that isn't something the retropie project maintains.



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.