Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

RetroPie and lr-dolphin (Gamecube)



  • Hello,

    This is more of a very general question. I'm running the latest version of RetroPie on a laptop, running Linux Mint 18.1. I'm pretty familiar with RetroPie and have it pretty much all set up, but have a question about the Dolphin emulator.

    I know Dolphin is an experimental package, so any issues probably are expected. But it seems that when running dolphin-emu-nogui (which is what RetroPie uses as a default for GameCube games), the emulator uses default keyboard controls and ignores any controller configurations you setup in the Dolphin GUI, even if you overwrite the default INI files.

    After lots of searching, it seems just to be a bug with Dolphin. I tried setting up RetroPie to run Dolphin without the "nogui" command, and the controls will work until I unplug a controller or something like that.

    This is where the libretro architecture is awesome, and with RetroPie, obviously any controller you setup will work the right way with all of the libretro cores. So, I noticed the RetroArch site does have builds for a lr-dolphin core, but the RetroPie setup script only lets you install a non LR version of Dolphin.

    That was really long winded, but... is there anyway I can manually add the lr-dolphin core to RetroPie? Or does anyone happen to know if this is on the list of things to add? I tried creating an lr-dolphin folder with the rest of the cores in the /opt/retropie/libretrocores folder, and putting the core in the folder, but I'm assuming it's not that easily.

    Thanks in advance!



  • @retrogamer0897 said in RetroPie and lr-dolphin (Gamecube):

    anually

    there is currently a $175 bounty for dophin to be ported to arm64 no ones done it yet time will tell but there is condition by the author so it cant be the usual pick a version hack it up and wait a year or two before updating again.

    It will be nice to see a core integrated in RA istead of broken apart it means it can stay upstream. If your using X86 why dont you just use stand alone it works



  • @grant2258 Thank you for the response! I certainly can use the standalone version, which I will probably end up doing. I want to eventually (possibly) replace my Raspberry Pi with a small laptop that runs RetroPie, since I have access to better hardware. So I was hoping to setup a system I can connect to the TV and use the interface entirely with the controller.

    I'll just have to make due for now, and choose a solution that suits me best.



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.