Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

Retroarch crashes when launching nes and snes games (but not genesis)



  • I'll try to use the fsck command...



  • Its not working 😢



  • Here's the entire log :

    Parameters: 
    Executing: /opt/retropie/emulators/retroarch/bin/retroarch -L /opt/retropie/libretrocores/lr-nestopia/nestopia_libretro.so --config /opt/retropie/configs/nes/retroarch.cfg "/home/pi/RetroPie/roms/nes/Super Mario Bros. (Japan, USA).nes" --verbose --appendconfig /dev/shm/retroarch.cfg
    [WARN] screenshot_directory is not an existing directory, ignoring ...
    [WARN] savefile_directory is not a directory, ignoring ...
    [WARN] savestate_directory is not a directory, ignoring ...
    [INFO] RetroArch 1.7.3 (Git b2ceb50)
    [INFO] Redirecting save file to "/home/pi/RetroPie/roms/nes/Super Mario Bros. (Japan, USA).srm".
    [INFO] Redirecting savestate to "/home/pi/RetroPie/roms/nes/Super Mario Bros. (Japan, USA).state".
    [INFO] === Build =======================================
    Capabilities: NEON VFPv3 VFPv4 
    Built: May 14 2018
    [INFO] Version: 1.7.3
    [INFO] Git: b2ceb50
    [INFO] =================================================
    [INFO] Loading dynamic libretro core from: "/opt/retropie/libretrocores/lr-nestopia/nestopia_libretro.so"
    [INFO] [overrides] no core-specific overrides found at :\config/Nestopia/Nestopia.cfg.
    [INFO] [overrides] no game-specific overrides found at :\config/Nestopia/Super Mario Bros. (Japan, USA).cfg.
    [INFO] Shaders: preset directory: :\shaders/presets
    [INFO] Shaders: no game-specific preset found at :\shaders/presets/Nestopia/Super Mario Bros. (Japan, USA).cgp.
    [INFO] Shaders: no game-specific preset found at :\shaders/presets/Nestopia/Super Mario Bros. (Japan, USA).glslp.
    [INFO] Shaders: no parent-dir-specific preset found at :\shaders/presets/Nestopia/nes.cgp.
    [INFO] Shaders: no parent-dir-specific preset found at :\shaders/presets/Nestopia/nes.glslp.
    [INFO] Shaders: no core-specific preset found at :\shaders/presets/Nestopia/Nestopia.cgp.
    [INFO] Shaders: no core-specific preset found at :\shaders/presets/Nestopia/Nestopia.glslp.
    [INFO] Environ SET_VARIABLES.
    [INFO] Remaps: remap directory: /opt/retropie/configs/nes/
    [INFO] Remaps: no game-specific remap found at /opt/retropie/configs/nes/Nestopia/Super Mario Bros. (Japan, USA).rmp.
    [INFO] Remaps: no core-specific remap found at /opt/retropie/configs/nes/Nestopia/Nestopia.rmp.
    [INFO] Redirecting save file to "/home/pi/RetroPie/roms/nes/Super Mario Bros. (Japan, USA).srm".
    [INFO] Redirecting savestate to "/home/pi/RetroPie/roms/nes/Super Mario Bros. (Japan, USA).state".
    [INFO] Environ GET_LOG_INTERFACE.
    [INFO] Environ PERFORMANCE_LEVEL: 6.
    [INFO] Loading content file: /home/pi/RetroPie/roms/nes/Super Mario Bros. (Japan, USA).nes.
    [INFO] Did not find a valid content patch.
    [INFO] CRC32: 0x3337ec46 .
    [INFO] Environ SET_INPUT_DESCRIPTORS:
    [INFO] 	RetroPad, User 1, Button "B (bottom)" => "B"
    [INFO] 	RetroPad, User 1, Button "Y (left)" => "Turbo B"
    [INFO] 	RetroPad, User 1, Button "Select" => "Select"
    [INFO] 	RetroPad, User 1, Button "Start" => "Start"
    [INFO] 	RetroPad, User 1, Button "D-Pad Up" => "D-Pad Up"
    [INFO] 	RetroPad, User 1, Button "D-Pad Down" => "D-Pad Down"
    [INFO] 	RetroPad, User 1, Button "D-Pad Left" => "D-Pad Left"
    [INFO] 	RetroPad, User 1, Button "D-Pad Right" => "D-Pad Right"
    [INFO] 	RetroPad, User 1, Button "A (right)" => "A"
    [INFO] 	RetroPad, User 1, Button "X (up)" => "Turbo A"
    [INFO] 	RetroPad, User 1, Button "L" => "(FDS) Disk Side Change"
    [INFO] 	RetroPad, User 1, Button "R" => "(FDS) Eject Disk"
    [INFO] 	RetroPad, User 1, Button "L2" => "(VSSystem) Coin 1"
    [INFO] 	RetroPad, User 1, Button "R2" => "(VSSystem) Coin 2"
    [INFO] 	RetroPad, User 1, Button "L3" => "(Famicom) Microphone"
    [INFO] 	RetroPad, User 2, Button "B (bottom)" => "B"
    [INFO] 	RetroPad, User 2, Button "Y (left)" => "Turbo B"
    [INFO] 	RetroPad, User 2, Button "Select" => "Select"
    [INFO] 	RetroPad, User 2, Button "Start" => "Start"
    [INFO] 	RetroPad, User 2, Button "D-Pad Up" => "D-Pad Up"
    [INFO] 	RetroPad, User 2, Button "D-Pad Down" => "D-Pad Down"
    [INFO] 	RetroPad, User 2, Button "D-Pad Left" => "D-Pad Left"
    [INFO] 	RetroPad, User 2, Button "D-Pad Right" => "D-Pad Right"
    [INFO] 	RetroPad, User 2, Button "A (right)" => "A"
    [INFO] 	RetroPad, User 2, Button "X (up)" => "Turbo A"
    [INFO] 	RetroPad, User 2, Button "L" => "(FDS) Disk Side Change"
    [INFO] 	RetroPad, User 2, Button "R" => "(FDS) Eject Disk"
    [INFO] 	RetroPad, User 3, Button "B (bottom)" => "B"
    [INFO] 	RetroPad, User 3, Button "Y (left)" => "Turbo B"
    [INFO] 	RetroPad, User 3, Button "Select" => "Select"
    [INFO] 	RetroPad, User 3, Button "Start" => "Start"
    [INFO] 	RetroPad, User 3, Button "D-Pad Up" => "D-Pad Up"
    [INFO] 	RetroPad, User 3, Button "D-Pad Down" => "D-Pad Down"
    [INFO] 	RetroPad, User 3, Button "D-Pad Left" => "D-Pad Left"
    [INFO] 	RetroPad, User 3, Button "D-Pad Right" => "D-Pad Right"
    [INFO] 	RetroPad, User 3, Button "A (right)" => "A"
    [INFO] 	RetroPad, User 3, Button "X (up)" => "Turbo A"
    [INFO] 	RetroPad, User 3, Button "L" => "(FDS) Disk Side Change"
    [INFO] 	RetroPad, User 3, Button "R" => "(FDS) Eject Disk"
    [INFO] 	RetroPad, User 4, Button "B (bottom)" => "B"
    [INFO] 	RetroPad, User 4, Button "Y (left)" => "Turbo B"
    [INFO] 	RetroPad, User 4, Button "Select" => "Select"
    [INFO] 	RetroPad, User 4, Button "Start" => "Start"
    [INFO] 	RetroPad, User 4, Button "D-Pad Up" => "D-Pad Up"
    [INFO] 	RetroPad, User 4, Button "D-Pad Down" => "D-Pad Down"
    [INFO] 	RetroPad, User 4, Button "D-Pad Left" => "D-Pad Left"
    [INFO] 	RetroPad, User 4, Button "D-Pad Right" => "D-Pad Right"
    [INFO] 	RetroPad, User 4, Button "A (right)" => "A"
    [INFO] 	RetroPad, User 4, Button "X (up)" => "Turbo A"
    [INFO] 	RetroPad, User 4, Button "L" => "(FDS) Disk Side Change"
    [INFO] 	RetroPad, User 4, Button "R" => "(FDS) Eject Disk"
    [INFO] Environ SYSTEM_DIRECTORY: "/home/pi/RetroPie/BIOS".
    [libretro INFO] Custom palette path: /home/pi/RetroPie/BIOS/custom.pal
    [libretro WARN] custom.pal not found in system directory.
    [libretro INFO] NstDatabase.xml path: /home/pi/RetroPie/BIOS/NstDatabase.xml
    [INFO] Environ SET_PIXEL_FORMAT: XRGB8888.
    [INFO] Environ GET_VARIABLE nestopia_favored_system:
    [INFO] 	auto
    [INFO] Environ GET_VARIABLE nestopia_genie_distortion:
    [INFO] 	disabled
    [INFO] Environ GET_VARIABLE nestopia_ram_power_state:
    [INFO] 	0x00
    [INFO] Environ GET_VARIABLE nestopia_nospritelimit:
    [INFO] 	disabled
    [INFO] Environ GET_VARIABLE nestopia_overclock:
    [INFO] 	1x
    [INFO] Environ GET_VARIABLE nestopia_fds_auto_insert:
    [INFO] 	enabled
    [INFO] Environ GET_VARIABLE nestopia_blargg_ntsc_filter:
    [INFO] 	disabled
    [INFO] Environ GET_VARIABLE nestopia_palette:
    [INFO] 	cxa2025as
    [INFO] Environ GET_VARIABLE nestopia_overscan_v:
    [INFO] 	enabled
    [INFO] Environ GET_VARIABLE nestopia_overscan_h:
    [INFO] 	disabled
    [INFO] Environ GET_VARIABLE nestopia_aspect:
    [INFO] 	auto
    [INFO] Environ GET_VARIABLE nestopia_select_adapter:
    [INFO] 	auto
    [INFO] Environ GET_VARIABLE nestopia_turbo_pulse:
    [INFO] 	2
    [INFO] Environ SET_GEOMETRY.
    [INFO] SET_GEOMETRY: 256x224, aspect: 1.306.
    [INFO] Environ GET_VARIABLE nestopia_favored_system:
    [INFO] 	auto
    [INFO] Environ GET_VARIABLE nestopia_genie_distortion:
    [INFO] 	disabled
    [INFO] Environ GET_VARIABLE nestopia_ram_power_state:
    [INFO] 	0x00
    [INFO] Environ GET_VARIABLE nestopia_nospritelimit:
    [INFO] 	disabled
    [INFO] Environ GET_VARIABLE nestopia_overclock:
    [INFO] 	1x
    [INFO] Environ GET_VARIABLE nestopia_fds_auto_insert:
    [INFO] 	enabled
    [INFO] Environ GET_VARIABLE nestopia_blargg_ntsc_filter:
    [INFO] 	disabled
    [INFO] Environ GET_VARIABLE nestopia_palette:
    [INFO] 	cxa2025as
    [INFO] Environ GET_VARIABLE nestopia_overscan_v:
    [INFO] 	enabled
    [INFO] Environ GET_VARIABLE nestopia_overscan_h:
    [INFO] 	disabled
    [INFO] Environ GET_VARIABLE nestopia_aspect:
    [INFO] 	auto
    [INFO] Environ GET_VARIABLE nestopia_select_adapter:
    [INFO] 	auto
    [INFO] Environ GET_VARIABLE nestopia_turbo_pulse:
    [INFO] 	2
    [INFO] Environ SET_GEOMETRY.
    [libretro INFO] [Nestopia]: Machine is NTSC.
    [INFO] Skipping SRAM load..
    [INFO] Version of libretro API: 1
    [INFO] Compiled against API: 1
    [INFO] [Audio]: Set audio input rate to: 48000.00 Hz.
    [INFO] [Video]: Video @ 879x672
    [INFO] [EGL] Falling back to eglGetDisplay
    [INFO] [EGL]: EGL version: 1.4
    [INFO] [EGL]: Current context: 0x1.
    [INFO] [GL]: Found GL context: videocore
    [INFO] [GL]: Detecting screen resolution 1920x1080.
    [INFO] [EGL]: eglSwapInterval(1)
    [INFO] [GL]: Vendor: Broadcom, Renderer: VideoCore IV HW.
    [INFO] [GL]: Version: OpenGL ES 2.0.
    [INFO] Querying EGL extension: KHR_image => exists
    [WARN] [GL]: GLES implementation does not have BGRA8888 extension.
    32-bit path will require conversion.
    [INFO] [GL]: Using resolution 1920x1080
    [INFO] [GL]: Default shader backend found: glsl.
    [INFO] [Shader driver]: Using GLSL shader backend.
    [WARN] [GL]: Stock GLSL shaders will be used.
    [INFO] [GLSL]: Found GLSL vertex shader.
    [INFO] Shader log: Compiled
    [INFO] [GLSL]: Found GLSL fragment shader.
    [INFO] Shader log: Compiled
    [INFO] [GLSL]: Linking GLSL program.
    [INFO] [GLSL]: Found GLSL vertex shader.
    [INFO] Shader log: Compiled
    [INFO] [GLSL]: Found GLSL fragment shader.
    [INFO] Shader log: Compiled
    [INFO] [GLSL]: Linking GLSL program.
    [INFO] [GLSL]: Found GLSL vertex shader.
    [INFO] Shader log: Compiled
    [INFO] [GLSL]: Found GLSL fragment shader.
    [INFO] Shader log: Compiled
    [INFO] [GLSL]: Linking GLSL program.
    [INFO] Setting up menu pipeline shaders for XMB ... 
    [INFO] [GLSL]: Found GLSL vertex shader.
    [INFO] Shader log: Compiled
    [INFO] [GLSL]: Found GLSL fragment shader.
    [INFO] Shader log: Compiled
    [INFO] [GLSL]: Linking GLSL program.
    [INFO] [GLSL]: Found GLSL vertex shader.
    [INFO] Shader log: Compiled
    [INFO] [GLSL]: Found GLSL fragment shader.
    [INFO] Shader log: Compiled
    [INFO] [GLSL]: Linking GLSL program.
    [INFO] [GLSL]: Found GLSL vertex shader.
    [INFO] Shader log: Compiled
    [INFO] [GLSL]: Found GLSL fragment shader.
    [INFO] Shader log: Compiled
    [INFO] [GLSL]: Linking GLSL program.
    [INFO] [GLSL]: Found GLSL vertex shader.
    [INFO] Shader log: Compiled
    [INFO] [GLSL]: Found GLSL fragment shader.
    [INFO] Shader log: Compiled
    [INFO] [GLSL]: Linking GLSL program.
    [INFO] [GLSL]: Found GLSL vertex shader.
    [INFO] Shader log: Compiled
    [INFO] [GLSL]: Found GLSL fragment shader.
    [INFO] Shader log: Compiled
    [INFO] [GLSL]: Linking GLSL program.
    [INFO] [GLSL]: Found GLSL vertex shader.
    [INFO] Shader log: Compiled
    [INFO] [GLSL]: Found GLSL fragment shader.
    [INFO] Shader log: Compiled
    [INFO] [GLSL]: Linking GLSL program.
    [INFO] Resetting shader to defaults ... 
    [INFO] [GL]: Using 4 textures.
    [INFO] [GL]: Loaded 1 program(s).
    [INFO] [Font]: Using font rendering backend: freetype.
    [INFO] [Video]: Graphics driver did not initialize an input driver. Attempting to pick a suitable driver.
    [ERROR] Using the null input driver. RetroArch will ignore you.[INFO] [Video]: Found display server: null
    [INFO] [ALSA]: Using signed 16-bit format.
    [INFO] [ALSA]: Period size: 768 frames
    [INFO] [ALSA]: Buffer size: 3072 frames
    [INFO] [ALSA]: Can pause: yes.
    [INFO] [Menu]: Found menu display driver: "menu_display_gl".
    [ERROR] Failed to create rendering backend: freetype.
    Failed to open :\assets/xmb/retroactive/font.ttf: No such file or directory
    [ERROR] Failed to create rendering backend: stb.
    [INFO] [Font]: Using font rendering backend: bitmap.
    [ERROR] Failed to create rendering backend: freetype.
    Failed to open :\assets/xmb/retroactive/font.ttf: No such file or directory
    [ERROR] Failed to create rendering backend: stb.
    [INFO] [Font]: Using font rendering backend: bitmap.
    [INFO] [LED]: LED driver = 'null' 0x1f98cc
    [INFO] Initializing rewind buffer with size: 20 MB
    [INFO] Loading history file: [:\content_history.lpl].
    [INFO] Loading history file: [:\content_favorites.lpl].
    [INFO] Loading history file: [:\content_music_history.lpl].
    [INFO] Loading history file: [:\content_image_history.lpl].
    [INFO] [GL]: VSync => on
    [INFO] [EGL]: eglSwapInterval(1)
    /opt/retropie/supplementary/runcommand/runcommand.sh : ligne 1008 :  2888 Erreur de segmentation  /opt/retropie/emulators/retroarch/bin/retroarch -L /opt/retropie/libretrocores/lr-nestopia/nestopia_libretro.so --config /opt/retropie/configs/nes/retroarch.cfg "/home/pi/RetroPie/roms/nes/Super Mario Bros. (Japan, USA).nes" --verbose --appendconfig /dev/shm/retroarch.cfg
    


  • @pierouge said in Retroarch crashes when launching nes and snes games (but not genesis):

    [INFO] Did not find a valid content patch.

    It's likely that your NES roms lack headers. You can check by running the following command:

    file "/home/pi/RetroPie/roms/nes/Super Mario Bros. (Japan, USA).nes"

    Roms with headers will produce output like the following:

    Legend of Zelda.nes: iNES ROM dump, 8x16k PRG, 0x8k CHR, [Horiz.], [SRAM]

    If it's like below, then your rom has no header and will not work.

    Legend of Zelda.nes:data

    SNES emulation isn't affected by headerless roms so could you post the verbose logging output when launching a SNES rom at a site like https://pastebin.com/.


  • administrators

    @pierouge use pastebin for logs.



  • @dudleydes it's not that, i don't know what's going on but all of my systems (except genesis) crash... Any idea ?


  • Global Moderator

    @pierouge said in Retroarch crashes when launching nes and snes games (but not genesis):

    [WARN] screenshot_directory is not an existing directory, ignoring ...
    [WARN] savefile_directory is not a directory, ignoring ...
    [WARN] savestate_directory is not a directory, ignoring ...
    [INFO] RetroArch 1.7.3 (Git b2ceb50)

    Looking at the log file, it seems some configuration gone wrong. Are you using a 3rd party image or the standard RetroPie image ?



  • Final Line : Segmentation fault line 1008 (/opt/retropie/supplementary/runcommand/runcommand.sh)
    Anything about that ?



  • @mitu said in Retroarch crashes when launching nes and snes games (but not genesis):

    Also, please give more details about your system, as requested in https://retropie.org.uk/forum/topic/3/read-this-first.

    almost 20 days later with no info about your setup. i think more people would be inclined to offer help if you would simply post the requested information.



  • It's okay, it was from my config file...It works now ! thanks !


Log in to reply
 

Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.