Please do not post a support request without first reading and following the advice in

Retropie on odroid xu4, ubuntu 18, emulationstation issues

  • Hello, this is my first time using odroid xu4. I am running Ubuntu 18.04 LTS "bionic" from the emmc module from hardkernel. (I wasn't aware it would be 18.04 when I purchased it)

    I then followed the guide here...

    I know its for ubuntu16.04, but figured worth a shot on ubuntu 18.04.

    After following the guide, I had issues starting retroarch until I also installed the following packages

    sudo apt-get install libsdl2-dev libsdl2-image1.2-dev libsdl2-image-dev.

    I next tried to run emulationstation, but received errors related to SDL2 OpenGL

    lvl0: Error creating SDL window!
    Could not initialize OpenGL / GLES library

    I then realized, that I should be running emulation station without X. So I ran
    sudo service lightdm stop

    And then when I ran emulationstation from a non-X terminal, I received the following error:

    lvl0: 	Error initializing SDL!
    	No available video device
    lvl0: 	Renderer failed to initialize!
    lvl0: 	Window failed to initialize!

    Doing some searching, it seems like this may be relevant...?

    "RetroPi SDL2 uses Mali fbdev implementaion which won't work under X11.
    Default SDL2 from Ubuntu uses OpenGL as default renderer while ODROIDs only support OpenGL ES.

    That's probably your main issue here. Everything is using SDL2 and the SDL2 you use is 'broken'."

    I also followed the steps here, TL;DR (they have you create a small c++ program to test if openGL is working, and it worked for me), just to see if there were any issues with OpenGL, and it appears not.

    So I either made a mistake when trying to install retropie and build retroarch and emulationstation, or I am close but not sure how to proceed.

    I have the following questions...

    1. Am I close, meaning, should I continue with where I am at, or should I reimage? If I am close, does anyone have any suggestions on how I fix the error for emulation station, regarding SDL? If I should start over fresh, should I follow this guide?

    2. Am I supposed to run retroarch under X to configure inputs, save dirs, video, audio, etc, and then shutdown X and run emulationstation just for playing games?

    Thanks in advance...

  • Ok, I feel a bit silly now, but if anyone else runs into this, basically, just don't run the hardkernel image.

    I reimaged with the latest image from and it just came right up.
    Within minutes had Wifi and USB disk drive working. Just need to copy over ROMs now.

  • This post is deleted!

  • @tman77 wondering what your experience has been so far with this image. MLP has a 200GB image based on Team ORA 1.1 Retropie image. I came back to this image, adding roms with video snaps, however I can't make Dreamcast recognize my 8bitdo pro. I did try the reincast script, attached a keyboard, re-mapped the keys. No success. I haven't tried wired controllers, but WTF, I didn't pay 50 bucks a piece for these in order to play with cheap 10 dollar controllers. In the mean time, my RPI 3b+ works like a charm, except for N64 and Dreamcast.

Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.