Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

Amiberry - how to swap disks?



  • I've tried to find this answer many times and am still having difficulty. How do you swap from, say, disk 1 to disk 2 while playing a game with Amiberry?

    I can access the F12 menu of course and change floppy assignments there, but the change doesn't seem to register for the game; it still keeps asking for the next disk. Then, I just get stuck.

    What am I missing? Thanks!



  • @ctgriffi Judging from the Amiberry wiki pages on using disk files (ADF) or Harddrives (HDF), I believe using the WHDLoad Autobooter is the recommend approach in Amiberry.

    The WHDLoad Autobooter uses "Retroplay's WHD Games" which have a .lha extension. This will eliminate the need for disk-swapping.



  • @dudleydes

    I guess you're probably right, since the .adf disk how-to page in the wiki is completely blank. (It does seem surprising that the basic .adf disk option wouldn't have better support.)

    Thanks for the input.



  • @ctgriffi

    @dudleydes dudleydes is right, Amiberry is specfically targeted for use with WHD load, but disk swapping does work as I have used it.

    Is the same game you are getting the error with or a number of games? You are correct that you go into the menu (F12) and then just add the disk in place of the one you want to swap. You can also add the second disk to DF1 and see if that works. However, different Amiga games will only recongise a specfic numberof drives, and there does appears to a set rule for this. So a mutil disk game may only ever let you use DFO, and you have to keeo swapping.

    Anyway, let me know what you are trying to get to work, and I will try my end.



  • @tuki_cat

    Thanks for chiming in! I am, specifically, trying to get Another World to work via Amiberry, and I keep running into the disk swapping issue after completing the first level. I've tried multiple drives vs a single drive (DF0), always with the same results.

    Maybe I'll try a different rom to see if the game in question is the determining factor.

    Anyway, let me know if you get it working or have another approach that I've missed, please.



  • @ctgriffi i'll take a look tonight and let you know how I get on



  • @ctgriffi Hi, I have checked and I can swap disks fine.

    I didn't have the time to play through level 1 of Another World so I i tried a different multi-disk game.

    Heimdall uses disk 5 to boot, I then had to swap to disk 4. I did this by entering the Amiberry GUI and changing the disk in DF0: from disk 5 to 4, I resumed the game, it recognised the disk, so all is working.

    There are a couple of other things that could be the issue.

    1.) The .adf you have for Another World disk 2 is bad, so it is not being recognised when you mount it. Try another game with multi-disks to see if you can recreate the problem.

    2.) What speed do you have floppy drive emulation on? If you have the drive speeded up try changing it to 100% compatible. I know that some games have issues when the drive is run at a faster speed.

    Let me know how you get on.



  • I test to swap disks with another world. It work's. I start amiberry, then put the first disk in DF0, pass the first level. When it ask the disk 2, I press select + x to access the amiberry gui from my gamepad. Then I select the disk 2 in the DF0 drive, press resume, then press a button on my pad like the game ask. The level 2 loads, they save me from this beast to put me in a jail, why?
    Finally, every time i put a disk in DF0 I do it from the "floppy drives" menu, not from the "quickstart" menu, I don't know if it make a difference. I hope it will help you to play this very good game


Log in to reply
 

Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.