Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

RetroPie not booting after successful boot and shutdown



  • After successfully running RetroPie on a new install and shutting down, RetroPie will not reboot with power. I have seen similar issues posted, but no solution.

    I flashed the retropie-4.4-rpi2_rpi3 image on a SanDisk Ultra Plus 32 GB micro SD with Etcher and ran RetroPie on a Pi 3 B+ with no issues, played a few games, shut down through the menu and waited half an hour to be sure shutdown was complete before releasing the power button on my 2.5A Canakit power cable. Upon powering again nothing happens. The red light on the Pi shows it is receiving power, but nothing boots.

    After failing to boot and pulling the SD card to check on my PC, it notices there is an issue with the drive and asked to scan/fix. I can see the contents, but the capacity is reduced from 32 GB to ~57 MB. When I reformat with SDFormatter I am able to restore the initial capacity, reflash RetroPie and run again in the Pi without issue until restart. I have done this with the SanDisk card twice and once with a Samsung Evo Select 32 GB microSD. Same result. What could be corrupting my SD cards? What am I doing incorrectly?

    Specs:
    Raspberry Pi 3 B+
    CanaKit 2.5A Power Supply with micro USB power button
    Image: retropie-4.4-rpi2_rpi3
    SanDisk Ultra Plus 32 GB micro SD
    Verbatim keyboard connected
    2x iNNEXT controllers connected



  • @archer Can you SSH into the Pi on the second "blank" boot? It could just be an HDMI detection issue which can happen if you boot the Pi before the monitor/TV is fully powered up.

    Try adding

    hdmi_force_hotplug=1
    hdmi_drive=2

    to /boot/config.txt and see if that fixes the issue.

    Also, which Innext controllers are you using and do you like them?



  • @archer As a side note, the 57mb partition is the FAT partition created for the boot files which your computer can see but it doesn't see the second partition which is the linux file system partition that the Pi or a Linux machine would see.



  • @thedatacereal Thanks for the quick response, I can try that out tomorrow, though I am sure the TV I am using is powered up completely. I do also have a HDMI splitter that I can only change to the correct input after the Pi is powered on (if that could cause any issues?), but this is the same setup that works with a fresh install.

    P.S. I have the Innext SNES retro controllers. Used sparingly so far, but I like them, they play just like I remember. I should add they don't seem terribly robust and I'm a little worried I might damage them mashing on these old games...just like the real thing.



  • @archer Thanks, I was tempted to try them recently instead of getting more ibuffalos. I've been on a new controller binge buying several cheap ones and testing them out.

    Also, the card error you get is one I got a lot when putting my card into my Windows machine. I'm assuming it's due to a difference in the OS type change. I'd definitely try editing the config.txt and see if that solves your issue.



  • @thedatacereal Problem solved thanks to your input about HDMI detection. I switched the Pi output from HDMI splitter port 3 to port 1, the default when receiving any signal, and that seems to have done it. I also happened to reboot a few times while testing the SSH connection if that could have any impact, that was the only other change in my process. Thanks for your help!

    Also you should try out the controllers and let me know how they compare with ibuffalo.



  • @archer Glad it worked! Anytime I have issues with displays I try to SSH/SFTP in to see if the Pi is actually up and running or if it's just not booting.

    I have them in my Amazon cart , just waiting to pull the trigger 😁. I will let you know how they compare.


Log in to reply
 

Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.