Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

xbox 1 controller post pie issue



  • so after a lot of learning and setting up, i finally got my pie3b+ running smoothly. i hit a weird issue with my xbox one controller though (gen 1 xbox1 controller) i know the version i am using doesnt have bluetooth so i wired it in paired it and was using it wired no problem. but a couple days later i went to use the controller on my xbox1 console and now the controller cant pair to my xbox 1, i can use the controller wired to the xbox 1 and no issues but it will not wirelessly connect, this happened only after i wire paired it to the pie. still not sure why the controller will wire to my xbox one but can no longer pair to it wirelessly i have tried updating the controller (there was no updates) and i have tried formating the controller. nothing will get it to wirelessly pair to my xbox anymore.



  • If you have batteries in your controller and you wire it directly to your XBONE it should automatically transition to a wireless connection when the cable is removed.



  • i have tried this before i made this post and it will flash the xbox button (pairing mode) then just time out (also have to press the sync button on the side of the xbox 1 to put the xbox one in pair mode



  • @zacho95 I think it might just be your controller, I know you said you tried to update your controller on the XBONE, but try to do it on your PC, you will need to download the "Xbox Accessories" App from the MS Store to do it.
    If your controller really is that old, I have seen the wireless functionality die with those controllers after a long time.



  • i could see that being the issue but i feel this has to be software with how i was wirelessly playing my xbox fine then i play with the pay for a couple days then there on out the wireless is dead. but it is the OLDEST xbox 1 controller as it literally says DAY ONE printed on the surface of my controller. i will try the windows app tonight. and im very hesitant to try another xb1 controller atm.



  • @zacho95 Also another thing you can try is powering off the console, pulling the power cord/power supply, press the power button on the Xbone a couple of times to drain it, and then reboot and retry.
    I used to get paid to do this shit for Microsoft :)

    When you connect a controller to an XBONE via wired or wireless, it saves the ID of the console in the controller's memory, so if it is not connecting to it after all of these steps, it is probably the wireless functionality on the controller that is dead (in all my years of working we have not had the wireless adapter on the console side break). I have seen a lot of those original controllers break over the years :)

    Also if you have a friend with an XBONE, try to pair it to that console



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.