Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

full keyboard support for Libretro-tyrquake (Quake)



  • Hi all,

    I've been trying to use mouse and keyboard combo in the Pi port of Tyrquake but its like only a few keys on the keyboard are bound to be used and a majority of the keyboard doesn't do anything. I'm using RetroPie 3.8.1 with my kernel downgraded to 4.1.21-v7+ so my Xbox360 controller works. I tried changing the settings input_libretro_device_p1 = "3" in /opt/retropie/configs/ports/quake/retroarch.cfg and a few other random things but still only a few keys on the keyboard work. I would like to be able to press the Esc button to go to the menu, be able to rebind keys and be able to hit the tilde key to go to the console and be able to use every key on the keyboard to type in the console just like the good old MS-DOS version of Quake.

    Also any changes I make to /home/pi/RetroPie/roms/ports/quake/id1/config.cfg aren't used and get wiped out after launching Tyrquake. I've even tried chown to root:root on this config.cfg file so the changes won't be wiped out but Tyrquake just ignores them.

    Any advice?



  • I worked on this a little bit more last night while watching the Rio Olympics and this is what I got so far...

    nano /opt/retropie/configs/ports/quake/retroarch.cfg

    input_libretro_device_p1 = 3
    
    input_player1_a = "space"
    input_player1_b = "backslash"
    input_player1_y = "q"
    input_player1_x =
    input_player1_start = "escape"
    input_player1_select = "tab"
    input_player1_l = "a"
    input_player1_r = "d"
    input_player1_left = "left"
    input_player1_right = "right"
    input_player1_up = "w"
    input_player1_down = "s"
    input_player1_l2_btn =
    input_player1_r2_btn =
    input_player1_l3_btn =
    input_player1_r3_btn =
    
    # Hotkey button
    input_enable_hotkey_btn = "tab"
    # Exit emulator
    input_exit_emulator_btn = "x"
    input_exit_emulator = "del"
    

    The hotkeys to exit the emulator do not work for me and also the Esc key doesn't show Quake's menu. Right now the only way to exit Quake is to SSH in and administer the killall retroarch command.

    If anyone has any further customizations, please let me know.



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.