Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

  • Hello,

    I am a new user and so far I've been pretty satisfied with what the Pi has to offer, works like a charm and is very user-friendly! Now for my problem:

    I bought what looks like a PS3 Controller off of eBay. As soon as I connected it to my Pi it turns out the slimy little cunt had sold me a fake "Shanwan" one instead (granted, it WAS cheaper than the original one which should've made me suspicious... oh well). So now I'm stuck with a controller that, as soon as I plug it in, will not stop vibrating which may seem like a small nuisance but will get on my nerves after an extensive playing session. Now, I know there's a workaround and I've searched the forums etc. but all I get is some random code on a github site (which I don't remember the link of) and as a complete Retropie / Linux n00b I've got virtually no idea what to do with it. This community seems to have the knowledge so I'll try my luck in here; could someone explain to me, in playin english, how to not have a constantly vibrating controller in my hands?

    Here's what I use:
    Raspberry Pi model 3 B+
    Retropie off a pre-made image from the official site, version not sure, probably latest since I downloaded it a week ago. Yes I know I shouldn't write "latest" but I work with the information I have on my hands right now.
    Controller: As stated, a crappy fake Shanwan one.
    Emulator: Not sure if relevant, since it happens before I even start to use one: PCSX-rearmed non-lr
    How to replicate the problem: Plug the controller in.

    Any help would be greatly appreciated.


  • Update:

    Fantastic. After installing "Customsonyhid" NONE of my controllers, including the keyboard, now work. But the fake Shanwan controller doesn't vibrate anymore so there's that. -_-

  • Global Moderator

    @buraz said in SHANWAN PS3 Controller vibrating:

    Now, I know there's a workaround and I've searched the forums etc. but all I get is some random code on a github site (which I don't remember the link of) and as a complete Retropie / Linux n00b I've got virtually no idea what to do with it

    That's maybe the solution right there - what's the link you found ?
    Unrelated to the problem, this forum is used by users of all ages, so tone down the injective.


  • Here it is:
    https://github.com/RetroPie/RetroPie-Setup/pull/2252

    It references "Customhidsony". After a little bit of fiddling around I realized I can find that under the "driver packages" menu in Retropie settings. After installing it, everything stopped working (Fake PS3 Controller, Keyboard, Xbox controller, Logitech one, Speedlink one) so there's really nothing I can do anymore.

  • Global Moderator

    @buraz Use SSH to access the system and remove the driver. Once logged in via SSH, you can run

    sudo ~/RetroPie-Setup/retropie_setup.sh
    

    to get you the setup script menu.


  • @mitu Thank you very much for trying to help. It appears that the reason no inputs work anymore is because I tried to install said driver without the DSL cable plugged in. I'm an idiot, I know.

    I did, however mess around with my other SD card that also contains a Retropie image and got the controller working without vibrating by installing that same driver. What I'm doing right now is extracting all my roms to my PC (which is a 50 minutes process in itself), I will then continue to reflash the SD card with the faulty inputs.

    Could you just tell me this:
    Can I delete everything on that SD, using an SD card-to-usb adapter and empty that folder on my PC, then reflash it? Would that set everything back to ... uh, let's call it "Factory settings"?

    Greatly appreciate you taking time for my issues.

  • Global Moderator

    If you don't want to keep anything from the - damaged - installation, you can just repeat the initial installation from zero, i.e. reflash the card once you saved everything you wanted from it. There's no need for any additional deletes, the re-flash will erase everything on the card, just like a 'factory default' reset.


  • I too have a shanwan controller that always vibrates if you connect it by usb, but it works fine if you want to connect it by bluetooth.
    From the retropie setup go to "manage packages" then "manage driver packages" then "install ps3 controller" once this has installed go to"configure options" then "pair ps3 controller (clone support shanwan). Then configure controller in emulationstation. Job done, hope this helps.


  • I am new on these forums and am a new very pleased Retropie user. But I too have the same problem and I solved it just by unplugging and replugging the controller.

Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.