Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

Did something wrong and now I am locked out



  • This problem was first posted on link text, but re-reading the forum laws, it wasn't on conformity. If the moderation could please delete that, it would be great.

    Running retropie 4.4.2 in a raspberry pi 3, I'd installed the zerojay stuff to access this splash screen awesomeness, but even following the rules I didn't quite understand what to do. And in my improvise I messed up.
    searching for a way to activate this splash screen I selected "start on boot - enable" or something like this and now emulation station did not open anymore. The splash setup fail to create, and fails to install and I can't type anything.
    Putting my pendrive with Psx and Dreamcast games open kinda normal, but I can't change the option on Retropie Setup, error lv 12.
    SSH can't save any alterations to the script, says something about "permission error".
    Thanks for your attention and please help me.



  • If you can't change the scripts due to permission errors, try force-writing to it (in vi/vim it's w!) or trying to edit it as root. (Be careful what you change though!)

    Which script are you trying to edit?

    If all else fails, you can try backing up your data through ssh/sftp and reinstalling, but you should be able to disable the start on boot through the editor.


  • Global Moderator

    It's hard to say without knowing what you actually did (commands you run) and what is the error you're receiving. What I would do as first steps (using the RetroPie-Setup script):

    • Re-install the splashscreen module
    • Re-install Emulationstation
    • Reset permissions on the ROM folders
    • Re-configure the autostart part (it's in the Emulationstation package, the autologin selection).

    Failing that, post the exact error you're receiving and we might get a hint of what's wrong.



  • @capninja Can you please post output of cat /opt/retropie/configs/all/autostart.sh command?



  • @cyperghost
    When I open the file:
    emulationstation #auto

    @mitu

    the last command I've tried:

    sudo ./fun-facts-splashscreens.sh --enable-boot
    

    And then... Here I am.
    The log in Fun Facts Folder (just the last 2)

    2018-08-21 01:01:31 - (v2.0.0) ERROR: Unable to get the font from the 'zoid' theme files. << get_font create_fun_fact get_options --create-fun-fact
    2018-08-21 02:00:15 - (v2.0.0) Fun Facts! Splashscreen failed! << create_fun_fact_boot create_fun_fact get_options --create-fun-fact
    

    What I've found is this on
    ····/opt/retropie/supplementary/fun-facts-splashscreens

    # Enable/disable script at boot
    #
    # Boolean: true/false.
    boot_script = "true"
    

    I Have another eror, but this error I don't know where I can found on the files. Will take a picture of it and edit on this comment later.
    And I don't know how to enable permissions as well.

    I would happily reinstall any of your suggestions, but I don't know how.

    @circo

    try force-writing to it (in vi/vim it's w!)

    Sorry, I did not understand this part

    Thanks people for your time. Really

    alt text


  • Global Moderator

    @capninja said in Did something wrong and now I am locked out:

    I would happily reinstall any of your suggestions, but I don't know how.

    Go to each package I mentioned - in the RetroPie-Setup script - and use the update option for it.
    EDIT: Can you run the script with the --disable-boot option to make sure it's not starting on boot ? This way you should be able to have a normal start.
    The error you're receiving is (the font file not found) is because the script tries to find a font file from the theme you're using ('zoid') and it doesn't find one.



  • @mitu

    Go to each package I mentioned - in the RetroPie-Setup script - and use the update option for it.
    EDIT: Can you run the script with the --disable-boot option to make sure it's not starting on boot ? This way you should be able to have a normal start.

    I can't save any alteration. Permission Denied - Error code level 3 on WinSCH
    How can I override tis permission problem?


  • Global Moderator

    @capninja What exactly are you trying to do ? WinSCP is a file browser, it uses the pi user to access the Pi's OS and files. If a file is owned by the admin user - root - you won't be able to modify it from WinSCP directly.
    The disable command option should be executed from a command line (via SSH) with

    sudo ./fun-facts-splashscreens.sh --disable-boot
    


  • @mitu

    Edit1: Now I see a world of change. Thanks for the explanation, accessed with Putty and get this message

    sudo: /usr/bin/sudo must be owned by uid 0 and have the setuid bit get
    

    By the way, tried the login and password on the SSH section
    username: pigaming
    password: retropie
    and received the access denied, then tried "pi" and "raspberry" and got my access.

    Edit2: Trying your first suggestions, hee's the result:

    pi@retropie:~/RetroPie-Setup $ ./retropie_setup.sh
    Script must be run under sudo from the user you want to install for. Try 's     udo /home/pi/RetroPie-Setup/retropie_packages.sh'
    pi@retropie:~/RetroPie-Setup $ sudo /home/pi/RetroPie-Setup/retropie_packages.shsudo: /usr/bin/sudo must be owned by uid 0 and have the setuid bit set
    

    Then I tried this approach, given by edmaul69 and the same error show up again

    @cyperghost
    Re-reading your post, I guess I understand better your request. Here it is

    pi@retropie:~/RetroPie-Setup $ cat /opt/retopie/configs/all/autostart.sh
    cat: /opt/retopie/configs/all/autostart.sh: No such file or directory
    

    Did it right, right?



  • This post is deleted!

  • Global Moderator

    @capninja Well, you forcibly changed the files owner on - probably - the whole filesystem to the user pi and sudo doesn't work anymore (hence the error message). Here is a possible solution - https://askubuntu.com/questions/127446/how-to-fix-sudo-after-chmod-r-777-usr-bin - but fixing it requires starting the system in recovery mode (http://mapledyne.com/ideas/2015/8/4/reset-lost-admin-password-for-raspberry-pi).
    You'll probably have to also change the permissions on /etc/sudoers to 0440 and owner root:root through

    chmod 0440 /etc/sudoers
    chown root:root /etc/sudoers
    

    You'll need a keyboard to do the safe boot and permission changes, since single mode (recovery mode) boot will not start SSH or the network.



  • @mitu
    What I get now:

    /bin/sh: 0 can't access tty; job control turned off
    #
    

    And strangely my wireless usb keyboard doesn't respond on Raspbery anymore (working normal on the notebook)

    Edit: Thanks for all your time and dedication to my problem, I am embarassed of taking so much time from you. Gonna reinstall Retropie again and restart from scratch, maybe this will generate another thread (timid laughs), but again, thank you.


  • Global Moderator

    @capninja You're now dropped to a shell where you can execute commands as root. The # is the command line shell prompt. The usb keyboard problem could be because the USB drivers are not initialized in safe-mode.
    I think that the safest option is to re-install. There's too much fiddling with the CLI and it will be safer. Even if you managed to recover the sudo functionality, there's a high chance something else is broken and normal operations would not work.



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.