Please do not post a support request without first reading and following the advice in

cannot restore default controller functions retropie

  • I ended up attempting to configure my controller since one of my emulators was not responding and unintentionally wiped out the original configure. I now cannot exit a game in play while using any of the lr emulators, save or restore screenshots using LI 1 or R1. I have gone into Retro Config and restored and re did the configuration at start up but it does not restore the hot keys to exit or save / load. I have looked at the retroarch page to see if there is a way to fix this but I seem to have a hard time understanding the page. Is there anyone who could guide me to fix this ? I'm running a Pi3B. Not sure what version probably one of the latest. I'm using a PS1 USB controller and a USB Keyboard. My power supply is 5v 2amp.I'm also very new to the computer world so please be nice.

  • To add to my comment above. I have also watched several YouTube Videos and most of them are only showing how to config but seem to leave out the information on the Hot Keys which is the part that I do not know how to do example L1 Select (Load Save) R1 Select save and Select and Start ( Exit ) .

  • Global Moderator

    @europadecas said in cannot restore default controller functions retropie:

    seem to leave out the information on the Hot Keys which is the part that I do not know how to do example L1 Select (Load Save) R1 Select save and Select and Start ( Exit ) .

    They leave it out probably because it's already documented as part of the RetroArch doc page in and they think it's common knowledge.

    How did you do the modifications that broke your hotkeys ?

  • I must have a newer version . I followed the You Tube video on the link you sent however I could not translate his version with mine. I attempted and could not find the files. I do have a config file but not the same. My interface is different and I'm not sure where I would type those commands and if it would work the same. I feel bad that this seems like common knowledge to most. My hot keys ceased to work once I hit " configure input " . Please see screenshot below it also incudes my version I believe. I attempted to configure because one out of two of my PSX emulators were failing to operate with the controller. Please let me know if there is an easier way to get me back on track. Please see my screenshot below

  • 0_1535778300558_IMG_1807.JPG

  • @europadecas Please give us the output of this command in the Retropie console that you land in by pressing F4 in Emulation Station, or by logging into Retropie via SSH:

    grep -e input_enable_hotkey_btn -e input_exit_emulator_btn /opt/retropie/configs/all/retroarch.cfg

    It should display the lines where the hotkey and exit buttons are configured globally (or not). If they are mapped correctly there, we can proceed to look into core or game input overrides.

    Alternatively, you can just look into the file /opt/retropie/configs/all/retroarch.cfg and search for input_enable_hotkey_btn and input_exit_emulator_btn by your preferred method.

  • @clyde
    Okay I typed the command "grep e" exactly like shown . It shows in pink "input_enable_hotkey_btn " with blue =
    then below in green pi@retropi: $

    I tried the "/opt/ retropie/configs and it states "permission denied"

    What do you recommend next?

  • This is what I get when typing those commands. Hopefully you can see it.0_1535823628548_IMG_1811.JPG

  • I figured out what this major malfunction is. I know most of you probably already know what you are doing but if your really new to all this stuff like me , I will mention where I took a wrong turn. When I reconfigured my controller I failed to set the single hot key to select. I falsely assumed that the hot keys were more than 1 hot key for example "start and select" back out. When I went back to set my single hot key to select , the hot keys acted normally like they did prior, I just did not know that the hot key should be set to select.

  • @europadecas Yeah, the output from the command showed that no hotkey button is set. Do I understand you correctly that your problem is solved now? Then all that remains is to thank you for sharing the solution for others with the same problem.

  • Yes , problem is solved. I do thank you very much for your support. I would not have a Pi if my son never got me one and it has been a real learning process for me to figure it out. The support I have gotten on this forum has been a really good tool .

  • @europadecas Despite my arcade, electronics, Linux, and coding experience I found Retropie to be a very complex and difficult to manage project. Kudos to the devs for integrating this many emulators into a single environment, and kudos to the support forum here for the help!

Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.