Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

Pi3B - Paired Keycool SP64 BTLE Keyboard but no input



  • I just picked up a bluetooth Keycool KC-SP64 (https://www.massdrop.com/buy/keycool-kc-sp64-bluetooth-mini-mechanical-keyboard) keyboard from massdrop, and wanted to use it with my bluetooth mouse in retropie (adventure games through scummvm, etc.) The keyboard itself is listed as bluetooth 4.0 with LE.

    I can get it to show up and it seems to pair through bluetooth configuration (appears as registered and active connection), but sending key presses doesn't register anywhere I try, in a shell prompt or in the ui as far as I can tell (my 8bitdo SNES and bluetooth 3.0 mouse pair and work fine.)

    I've tried pairing directly in bluetoothctl, and again, it seems to be active when it's paired. Unlike my mouse I have paired, the keyboard appears to connect and disconnect when not it use, but reconnects when I tap a key (is this normal for bluetooth le?)

    I've tried:
    -unpairing and re-pairing it numerous times
    -factory reset of keyboard itself
    -removing all other bluetooth devices from registered, and pairing just the kb
    -updating retropie software
    -ensuring it is set to pair on startup
    -compiling and installing BlueZ 5.50

    Has anyone run into this kind of behavior? It looks like the 3b should have no problem with bluetooth 4.0 le devices.

    Cheers. Anything else I should try?



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.