Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

Still no sound in Mame Space Invaders...



  • Hi all

    I'm using a Raspberry Pi3b and RetroArch with the various versions of Mame.... 2003, 4 all, 2010, liberatro

    Having done the research here and elsewhere I note sound samples are needed for space invaders. I've got them and obtained different back up samples from other sources. I've installed them as per widely circulated instructions, but still no sound...

    I've even checked the 'all config' file, which has Mame samples enabled...so I'm wondering, when you've done everything everyone recommends, whats next?



  • @picard999 You have not posted details of either the samples you are trying or where you have placed them and what you have actually tried. I use Advance MAME for this game and all the sounds work.



  • Hi Rbaker.

    I have followed standard internet instructions re space invaders sample file named invaders.zip. I have placed it in Rp/bios/mame2003/samples/

    I have also noted there are other versions of mame in my setup, so Ive also placed the same file in all the other sample folders that the various other incarnations of Mame use....

    Still no sound!

    Very frustrating

    Any help much appreciated



  • Ok, spooky

    Putting the samples folder in all the different versions of mame I found on my Pi caused 2 extra mame icons to appear on the ES menu. Clicking on them showed a samples folder. Clicking on that loaded space invaders that ran at 300% speed with sound! But not controllable with my gamepad

    Strange business indeed!



  • Ever get the feeling you're talking to yourself?

    So, here's the solution to the 'No sound in Space Invaders' problem, if nothing else has worked...kudos to Rbaker for setting me on the path to a fix

    if you haven't got advancemame installed then install it. Browse your retropie install via your chosen method (I networked from my PC)

    GO TO RETROPIE/ROMS/ARCADE/ADVMAME/SAMPLE/ and put the invaders.zip in there (not the invaders.zip game file that's about 5k - that's elsewhere within retropie and advmame seems happy enough to run it from there, but the invaders.zip file that's the sound sample, about 250k - google is your friend)

    Run retropie and for me an extra Mame icon appeared on the carousel, completely separate from my main Mame install with 3000 games. Click on that to reveal the Space Invaders rom, click on the rom to run the game

    For some reason, despite everything else in retropie just working with my joystick, Adv Mame Space Invaders didn't!

    Press Tab (you'll need a keyboard) and choose 'change settings for this game'. Move up and down using your keyboard d-pad and enter to choose which input to change....move your joystick to select which button you want or action you want for left, right, fire etc. Once done, why not change settings for the entire emulator, not just this game - that way you can use the joystick instead of keyboard to control the emulator menu screens. Simply select the joystick actions you want to use to navigate the advmame settings page, which action brings up the page (instead of tab) and which key crashes you back to the main Retropie carousel)

    Oh, when you're done, be sure to play Space Invaders - with sound and joystick control. Having spent 5 hours getting iti to work, you'll play for 20 seconds before realizing its too damn hard!

    Still cant get me wireless keyboard fully working in retropie....the touch trackpad works, the d-pad substitute works, but in things like the speccy emu, when you need to press a number....nothing...

    Another day will doubtless bring the solution....



  • @picard999 said in Still no sound in Mame Space Invaders...:

    For some reason, despite everything else in retropie just working with my joystick, Adv Mame Space Invaders didn't!

    You need to read the docs more closely. Advance Mame is not a libretro emulator and must be configured differently by using the TAB command. The initial configuration screen will only configure emulators preceded with "lr". You should also consider using the Arcade folder for all arcade emulation and use the run command to select the different emulators that you would like to use to launch each rom. 3000 roms in there seems too many to manage. I have around 200 classics.



  • @picard999 said in Still no sound in Mame Space Invaders...:

    Oh, when you're done, be sure to play Space Invaders - with sound and joystick control. Having spent 5 hours getting iti to work, you'll play for 20 seconds before realizing its too damn hard!

    Yeah, hehe. Your thread prodded me to play SA for the first time in years, and it was too damn hard for me, too. 😮 😉


Log in to reply
 

Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.