Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

save configuration on exit issue



  • the save config on exit no longer works from rgui I have experienced that as well as read others on hear complain on it.( not really sure why that was taken away) . AnywayI enabled it in the configuration editor and enable bilinear filtering because it would never save when i tried to do it through rgui even when i have save on exit config enabled also through rgui. So anyway prior to enabling save config on exit in the configuration editor the analog controller l3 button I had setup in rgui and for some reason it always worked. Once i utilized the configuration editor and enabled save config on exit the setting for the l3 analog to be actived never saves on exit. I literally have to enable it every time. In the future releases please bring back the ability to easily use rgui.

    im on rpi3 using 3.8





  • @meleu sort of ... my issue is I know save on exit has to be enabled in the editor which I have done. however once I did that my setting for the analog l3 button to be enabled defaults to not being enabled and I have to go into rgui and enable it again. Once I exit the game it again returns to not being enabled. I'm lost here at this point. I have yet to get 3.7 or 3.8 up and running flawlessly as in previous versions. A lot of things are inconsitant imo


  • Global Moderator

    @smoothmalik did you enable save on exit via the configuration editor (NOT the rgui) for ALL libretro emulators? Otherwise it won't stay set.

    if so, upload contents of /opt/retropie/configs/all/retroarch.cfg



  • I enabled save config on exit on the configuration editor. Prior to me enabling it in the configuration editor the option to enable the analog stick on my ps3 stayed when using rgui. Once i enabled save on exit in conf editor I now have to enable in rgui each time i exit a game and start a new game even within the same emulator. Here is my config file.

    http://pastebin.com/Hn4A8enX



  • I'll paste here what I said in RetroArch Config Confusion and Issues. It's a bit long, but I think it has something to do with your problem (sorry if you've read this):

    I was very confused about these RGUI configs too. And then I realized that RetroPie wasn't made to work very "integrated" with RetroArch GUI by default (but RetroPie is very very flexible, and you can revert this with some knowledge).

    I think I can't help you directly to your issue, but maybe I can help you to understand some things... A bit of linux command line knowledge helps. Let's go:

    Take a look at the file /opt/retropie/configs/SYSTEMNAME/emulators.cfg (replace SYSTEMNAME with the obvious). You'll notice there are various commands to invoke an emulator, and the default is the default (oh really?) command used.

    You'll also notice that the commands invokes a specific config file. If you are using a libretro core, this config file is /opt/retropie/configs/SYSTEMNAME/retroarch.cfg. Go and take a look at some of these files.

    It exists to configure a specific core and also invokes the default configurations using the #include /opt/retropie/configs/all/retroarch.cfg. Keep in mind that the config uses the "first match if finds" approach, so for you override a global config, keep the #include line at the end of file.

    This approach can be a good thing for those who usually edit the retroarch.cfg "by hand". But for those who like to use RGUI, it can be annoying.

    Example of how annoying this can be:

    You invoke RGUI trhough RetroPie menu and enable "save config on exit" and then you can edit and save RetroArch configs via RGUI. The changes you make will be saved in /opt/retropie/configs/all/retroarch.cfg.

    Later you invoke RGUI during a NES game playing. You change some configs and then "Save config file". It'll save /opt/retropie/configs/nes/retroarch.cfg. This is the annoying thing! You think you saved the "default and only one retroarch.cfg", but you saved the specific retroarch.cfg for NES.

    Let's say you changed the On Screen Display text size to a bigger size using RGUI during this NES session, and saved. Then you quit and play Sonic (MegaDrive) and see that little yellow text again! You'll think "WHAT THE F#$@%CK?! I've just changed this text size!!!". But when you started the MegaDrive emulator the config file loaded was /opt/retropie/configs/megadrive/retroarch.cfg and you changed the text size only in the NES retroarch.cfg file.

    After a lot of confusion I finally learned to deal with config files by hand, but for those who aren't familiar with command line it can be hard...

    As a further reading, I suggest https://github.com/RetroPie/RetroPie-Setup/wiki/RetroArch-Configuration#hardcoded-configurations



  • I've put a brief overview on RGUI saving details here:



  • I dont think im explaining this well enough.. I have save on exit enabled through the config editor it stays enabled. However when I go into rgui to enable my ps3 controller with analog and chose to enable the left analog stick once I exit the game and restart the game these changes dont stay. I have yet to see somewhere in the config files where i can enbale analog controller and choose which analog stick I want to be active. There is an issue here. This has never been problem for me before these latest Retropie builds. I ususally just enable save on exit in rgui and everything stays. Not sure why it was changed but I assume to make things better somehow but doesnt seem to be helping out . Ive been at this for weeks just tryin to get this stuff to stay. Floob Ive watched all you videos and will continue to but for this specific issue that didnt help this time.



  • @smoothmalik What is the output of ls -lah /opt/retropie/configs/psx ?



  • I havent even bothered with getting playstation going yet ...Ive just been working on FBA but here is that file

    http://pastebin.com/uYnT3SXy



  • @smoothmalik Its just the output of the command above I'm after really.
    Which fba are you running?



  • pi@retropie:~ $ ls -lah /opt/retropie/configs/psx
    total 16K
    drwxr-xr-x 2 pi pi 4.0K May 27 16:14 .
    drwxr-xr-x 52 pi pi 4.0K May 27 16:16 ..
    -rw-r--r-- 1 pi pi 206 May 27 16:14 emulators.cfg
    -rw-r--r-- 1 pi pi 221 May 27 16:14 retroarch.cfg

    im running whatever version of FBA is on the 3.8 build. Im not running FBA Next or pifba



  • @smoothmalik fba-next is the default in 3.8 though?
    Can you run ls -lah /opt/retropie/configs/fba ?



  • im running just regular FBA

    here you go
    pi@retropie:~ $ ls -lah /opt/retropie/configs/fba
    total 176K
    drwxr-xr-x 2 pi pi 4.0K Jun 15 23:11 .
    drwxr-xr-x 52 pi pi 4.0K May 27 16:16 ..
    -rw-r--r-- 1 pi pi 195 May 27 16:13 capex.cfg
    -rw-r--r-- 1 pi pi 0 Jun 12 18:18 content_history.lpl
    -rw-r--r-- 1 pi pi 414 Jun 7 01:49 emulators.cfg
    -rw-r--r-- 1 pi pi 1.1K May 27 16:13 fba2x.cfg
    -rw-r--r-- 1 pi pi 49K Jun 15 23:12 fb_alpha_libretro-1.cfg
    -rw-r--r-- 1 pi pi 49K Jun 14 03:42 fb_alpha_libretro.cfg
    -rw-r--r-- 1 pi pi 46K Jun 16 00:33 retroarch.cfg
    -rw-r--r-- 1 pi pi 221 May 27 16:14 retroarch.cfg.rp-dist



  • @smoothmalik
    Whats the "default=" value show when you run nano /opt/retropie/configs/fba/emulators.cfg

    These 2 files are produced when you save in RGUI

    -rw-r--r-- 1 pi pi 49K Jun 15 23:12 fb_alpha_libretro-1.cfg
    -rw-r--r-- 1 pi pi 49K Jun 14 03:42 fb_alpha_libretro.cfg
    

    And by the looks of the file size of retroarch.cfg you have either renamed one of those files to be retroarch.cfg or you have added a lot of lines in there.

    The video above explains why RGUI produces the large 46k files and why RetroArch wont read them. It also shows how to rip the relevant line(s) out to add to the original (very small) retroarch.cfg file.



  • default="lr-fba"

    I havent renamed anything. I got desperate yesterday and today and tried to save the config file in rgui after I made some changes but of course they didnt stay. The only change ive made in retroarch.cfg was done in the config editor and that was enabling bilinear filtering (true) and save on exit (true).



  • @smoothmalik I'm assuming you have upgraded an older version of RetroPie.
    I would reset your RetroArch config with

    rm /opt/retropie/configs/fba/retroarch.cfg
    cp /opt/retropie/configs/fba/retroarch.cfg.rp-dist /opt/retropie/configs/fba/retroarch.cfg
    

    Then go back in the config editor, just enable bilinear filtering, then pastebin your /opt/retropie/configs/fba/retroarch.cfg



  • i didnt get far

    pi@retropie:~ $ rm /opt/retropie/configs/fba/retroarch.cfg
    rm: cannot remove ‘/opt/retropie/configs/fba/retroarch.cfg’: No such file or directory

    I also tried removing though ftp also wouldnt let me



  • Thats odd?

    This should show its there
    ls /opt/retropie/configs/fba/r*

    This should remove the old one
    rm /opt/retropie/configs/fba/retroarch.cfg

    unless you ran it twice, so its not there now?



  • here the paste bin. Bilinear filtering reamained enabled and so did save on exit. The retroarch.cfg file is 46.1 kb now

    http://pastebin.com/uYnT3SXy

    I got the left joystick working in config editor.


Log in to reply
 

Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.