Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

Multiple scraper issues (ES, SSelph, Skyscraper)



  • RetroPie 4.4.3, RPi 3, using the retropie image and then updated via retropie_setup.
    When running the EmulationStation scraper, it will grab a few (4-6) games, and then just stop. If I hit a key it will skip a game, and then continue for another 4-6 games, and then stop again. If I go back and re-run it, it will fill in the missing game, so it's not a corrupt ROM as far as I can tell.
    The Stephen Selph scraper doesn't show up in retropie_setup as something I can install, in either the optional or experimental packages list.
    Skyscraper installs and runs, but it says "Couldn't calculate sha1 hash sum of rom file '', please check permissions and try again, now exiting..."

    I have my ROMs on a USB flash drive which is auto-mounted via usbromservice.

    Any thoughts?
    Thanks!


  • Global Moderator

    @ExplodingLemur Stephen Selph's scraper can also be installed the Configuration/Tools menu - it's strange as I don't see it in the optional package section either.
    For Skyscraper - what scraping source are you using ? Are your ROMs zipped ?


  • Global Moderator

    For Skyscraper, there is a bug in the module, but will be fixed - you can work around by enabling the Use ROM dir for gamelists and media in the GUI.



  • @mitu said in Multiple scraper issues (ES, SSelph, Skyscraper):

    @ExplodingLemur Stephen Selph's scraper can also be installed the Configuration/Tools menu - it's strange as I don't see it in the optional package section either.

    I'll check in the Config/Tools menu, thanks!

    For Skyscraper - what scraping source are you using ? Are your ROMs zipped ?

    I'm using the default for Skyscraper, screenscraper.fr. MAME ROMs are zipped, ROMs for other systems may or may not be zipped.

    For Skyscraper, there is a bug in the module, but will be fixed - you can work around by enabling the Use ROM dir for gamelists and media in the GUI.

    Ok, I'll give that a try.

    Thank you!



  • @mitu said in Multiple scraper issues (ES, SSelph, Skyscraper):

    @ExplodingLemur Stephen Selph's scraper can also be installed the Configuration/Tools menu - it's strange as I don't see it in the optional package section either.

    Hm, I don't have it in Configuration/Tools either.



  • @mitu said in Multiple scraper issues (ES, SSelph, Skyscraper):

    For Skyscraper, there is a bug in the module, but will be fixed - you can work around by enabling the Use ROM dir for gamelists and media in the GUI.

    That's working. It's exceptionally slow, though. I'll try with other sources.


  • administrators

    I broke the scraper so it was hidden. Update RetroPie-Setup and it should back again. Thanks @mitu for the heads up.



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.