Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

  • I've been trying to resolve an audio issue for the past couple of hours and figured it was time to ask for help.

    My issue is that I don't have any sound for video snaps or emulation using the 3.5mm port (my only option for this build). I have startup videos and background music enabled and I get perfect sound from both of those but no sound from snaps or when playing games. I can fix this by going into Retropie -> Audio and setting audio to HDMI and then back to 3.5mm but whenever I restart the system the sound is gone again and I have to repeat the process. Also, just selecting 3.5mm doesn't work unless I select another option first and then go back in and select 3.5mm.

    In Start -> Sound Settings my settings are:
    System Volume: 100%
    Audio Device PCM
    Enable Navigation Sounds: On
    Enable Video Audio: On
    OMX Player Audio Device: Both

    And here's a copy of my command.txt: https://pastebin.com/B1evxCfj


  • @AtTheArcade the video snaps are controlled via the omx player device.
    Also, your options should stay saved when you restart unless you're looking the process? Is it only one option that doesn't stick or does no option save?


  • @pjft I actually didn't have OMX turned off for the video snaps (I forgot to change that setting on in this new build) but after I turned it on the video snaps had audio even after a reboot. My emulator (exclusively MAME-2003 for this build) still doesn't have sound though unless I follow the steps above of going into options, audio, switching to something other than 3.5mm, then switching back to 3.5mm.


  • @AtTheArcade the emulator audio isn't really configured in ES - I imagine that it's an unintended side effect that it works like that. I imagine you need to configure it in /boot/config.txt though I don't know those options by heart.

    Check https://www.raspberrypi.org/documentation/configuration/audio-config.md and https://raspberrypi.stackexchange.com/questions/61298/force-sound-over-3-5mm-jack-and-video-over-hdmi .

  • Global Moderator

    The audio settings in RetroPie use amixer to set the sound output, exactly as described in the 2nd link, then store the configuration using alsactl store( link to source ).
    Since the modifications don't seem to persist, I suggest running the 2 commands manually and see if any errors are shown.
    @AtTheArcade you didn't give any indications about your system and what's connected to it (as asked in https://retropie.org.uk/forum/topic/3/read-this-first), so it's hard to say why this setting does not work.


  • As a part of my troubleshooting yesterday I did do all three things mentioned in that first link.

    Here's what happens with I try to run the amixer cset numid=3 1 command via terminal:

    numid=3,iface=MIXER,name='PCM Playback Route'
      ; type=INTEGER,access=rw------,values=1,min=0,max=2,step=0
      : values=1
    

    Pi Model or other hardware: 3 B+
    Power Supply used: 5V 3A
    RetroPie Version Used: 4.4
    Built From: Image on Retropie website
    USB Devices connected: Controller
    Controller used: Generic USB SNES style controller
    Error messages received: None

  • Global Moderator

    @AtTheArcade The output is normal, but there's 1 more command

    sudo amixer cset numid=3 1
    sudo alsactl store
    

    reboot and see if the sound settings are persisted.


  • @mitu That seems to have fixed it! I've rebooted a few times and the sound works after each reboot! I really appreciate the help!!!!

Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.