Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

Black screen when RPI3 is connected to computer monitor



  • So the monitor goes into power saving mode (black screen) when connect to RPI3 via HDMI female to DVI male. When I disconnect the HDMI from my RPI3 the monitor turns back on. The Pi works perfectly fine on my TV though. I also tried going into config.txt but nothing worked. This is also not an isolated issue as I tried connecting the monitor to my laptop, not even that worked.

    Is there anyone who has had the same issue or have found a solution?

    I have read and tried countless solutions like disconnecting everything for 30 seconds and turn everything back on, replacing the wires, go into config.txt and etc. At this point I feel like I've tried everything and maybe there's something so obvious that I've missed.

    Help me RetroPie Forum, you're my only hope.



  • Does the raspberry pi not boot only on this monitor or does it not boot on every monitor?

    I would suggest you create a backup of any roms you have on the card, and re-install the RetroPie software.

    You might also need to change the card, as it could be counterfeit. These two reasons are mainly, in my experience, what cause problems with booting. Lastly it could just be due to your monitors, or even the Pi. I think hardware is the issue.

    If you don't mind me asking, what brand is the card, how much did it cost and where did you buy it from?



  • Does your monitor use a laptop like power supply? If so you might be running into a floating ground problem. I had this with a cheap power supply that came with a case I got.

    If you have a mobile phone charger try that if the monitor works you need to change your power supply.


  • Global Moderator

    @TheSpottedEagle You should try forcing a resolution and instruct the PI to ignore the EDID info from the monitor (see the hdmi_ignore_edit , hdmi_ignore_edit_audio and hdmi_force_hotplug described in https://www.raspberrypi.org/documentation/configuration/config-txt/video.md).
    You can try to find the correct resolution and hdmi_mode by playing from the command line (or via SSH) with tvservice: list the available supported modes and try to switch the resolution using this command until you may be able to display something on the monitor.

    What monitor model do you have ? Lastly, since you have the same problem with your laptop, you might want to try another HDMI/DVI cable if you have it, just to rule out a bad cable.



  • @Nicky_S14 The RPI3 boots on every monitor expect the one I'm using now. I have also tried re-installing the retropie software but nothing shows up in the screen. I have brand name micro SD card that I bought in person at a local electronics store so it being counterfeit is not the problem. It's a Sandisk 64 Gb. I have also tried another micro SD card with the same issue happening.

    I've came with the conclusion that the source of the problem might be the monitor itself. It seems that it's not isolated to one brand of computer monitor but various. I just unfortunately fell into this problem.



  • @mitu I've tried that also with no luck. I feel like I've just about tried everything in config.txt. from un-commenting to trying hdmi_safe adding script "hdmi_force_hotplug=1,
    "hdmi_ignore_edid=0xa5000080" and so on.

    The computer monitor I'm using is 19" Dell model 1905FP. I've ruled out the cables also tried that. So it has to be the monitor. I've yet to find a solution about this but so far I'm having no luck. There's just no one or haven't come across someone having the same issue.



  • @grant2258 The monitor is not running a laptop like power supply, it has its own. I've tried another power cord but still nothing works



  • going from experience with this you have a few choices and one i really bad and not recommended (3) .I had problems with the Dell S2440LB.

    1. replace the pi psu with offial one or test with a phone charger before commiting
    2. use the vga port instead
    3. make sure the pi and monitor are sharing the same earth reference since the pi is floating the psu should be taking care of this using option 1


  • @grant2258 I tried switching the VGA port using an HDMI to VGA option and it worked! I'm a little confused to why the DVI is having problems getting a signal from devices but... Whatever.
    Thank you for the suggestion. I guess it was a bit obvious to solve huh. I didn't think it would be as easy as just switching the ports.



  • get another power supply (a known good one) to fix your monitor if you want the hdmi else just stick to the VGA as long its working for you its all good :)



  • @TheSpottedEagle
    Hi , i have got the same monitor and same issue that no matter what i can not find a solution. Did you manage to sorted out?? I getting crazy to find the source if the issue. Note: stop working just few days ago. I am not using an official psu for the pi. Thanks



  • after investigating a little further i did indeed find another issue i bought a cheapo hdi cable it did work on most other things but not on the pi with this monitor. i think the pi is hdmi 1.3a i would recommend you get a 1.4 compatible cable at the very least.



  • @grant2258 thanks, i will try it.



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.