Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

Controller mapping seems to change depending on the game/console



  • Hello,

    I just installed RetroPie on my Raspberry 3B+.
    I linked my PS4 controller (DualShock 4 V2) and everything worked!
    I mapped it to the appropriate control in RetroPie without any issues.

    I played a gameboy color game (Zelda : Oracle of ages) and the mapping seemed to be right depending on what I configured few minutes ago.

    My issue : I launched a nintendo 64 game (Zelda : Ocarina of time) and the mapping seemed changed.
    The "A" button in the game was mapped to the "B" button according to my Retropie configuration.
    The "B" button in the game was mapped to the "Y" button according to my retropie configuration.

    Not really important but my main issue is: My hotkey button is not working anymore.
    So I'm not able to save the state of my game. Or to leave the game properly...

    I checked the configuration after the restart but everything was fine according to Retropie...

    Have you got any similar issue/answer about that ?

    Sub-question: (I will be honnest I didn't search it before because I prefer to save the state) I tried to save my game in the classical way (via the in-game menu) but at the next launch my save was not present. Should I configure something special about it ?

    I'm not a native speaker so excuse me for the mistakes I made.

    Thanks in advance for you help :-)


  • Global Moderator

    Which emulator are you using for N64 games ? If it's a non-lr emulator (i.e. Mupen64plus) the mappings are not 100% the same as for lr-mupen64plus (libretro) based emulators. You can check your gamepad mapping in the Mupen64plus configuration file - see https://retropie.org.uk/docs/Nintendo-64/ for a detailed explanation.



  • Thanks for you answer!

    I didn't know about the different emulators but I was using Mupen64plus which has his own config...
    I tried lr-mupen64plus but the cinematics appears black sometimes and the game crashed a few times...

    So a (re)switch on Mupen64plus.

    Just in case someone has the same issue I drop here the configuration issue I had:
    In the config file (/opt/retropie/configs/from_retropie/configs/n64/mupen64plus.cfg) I had this line:

    # Joystick event string for stopping the emulator
    Joy Mapping Stop = "J1B10/B9"
    

    The combination B10 (hotkeys) and B9 (start) seems to be ok for me BUT my controller was J0 not J1. It fix the "stop emulator" command. Now I have to check for the load/save state commands.

    Thanks again for you answer. It really helped me :-)



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.