Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

Retropie during emulation appears zoomed in and cut off



  • Greetings everyone. I have been banging my head on this one for days now and I swear I am going to loose my mind. I'm hoping someone has run into this before?

    Overall I have a Pi3 running Retropie to HDMI to an old plasma TV (its like a 720?).

    The entire menu system works great, looks great, even the emulation itself is working .. its just zoomed in and cropped. I have tried editing things in configuration editor, retroarc, etc .. and no matter what i do its always zoomed in. Any suggestions? Since its only the emulation that's having a problem I am assuming its not the TV setting. What's even weirder is any overlays (in this instance I'm using one that makes it look like an old TV) is perfect but the emulation itself zoomed under the overlay. Any suggestions? (pics below)

    so as you can see this looks great for the most part
    ngeo1.jpg

    but here its zoomed in
    ngeo2.jpg


  • administrators

    @jabbyjim check the documentation.

    https://retropie.org.uk/docs/Overscan/

    Your TV may treat different resolutions differently also. If you have been fiddling with settings you may want to start from a fresh image as you may have changed something that won't help.



  • thank you, I actually read and tried this earlier with no luck. It only did the same thing, but only within a smaller box on the screen. It looked even worse and it effected the menu and everything else as well which was no good.


  • administrators

    @jabbyjim Please supply more information about the set-up

    To help us help you - please make sure you read the sticky topics before posting - https://retropie.org.uk/forum/topic/3/read-this-first

    Did you change any video modes via runcommand ? Did you download the image from the RetroPie website ?

    Which emulators have you tested that it affects ?

    ES looks like it is affected by overscan so the overscan settings should help.

    Please post your config.txt after changing the overscan settings as detailed in the link above.



  • thank you. I did not change any video modes via run command. Not even sure how to do this? I know during emulation you can make changes but I can't see the options because the screen is so zoomed in I can only see the first few options. Same for changing emulators but I may be wrong with that as well.

    I may need to switch emulators but I'm not 100% how to do this through the CLI / config menu's ATM. I'm going to take a stab at that too. Update: I was already using lr-fbalpha (NEOGEO), and tried switching to pifba but got a black screen no sound no nothing (so worse). Thinking I can update the emulator software and have better results? worth a try.

    OK I tried editing the config.txt and it didn't make a difference in the menu or the emulation.

    here is the current config.txt

    # For more options and information see
    # http://rpf.io/configtxtreadme
    # Some settings may impact device functionality. See link above for details
    
    # uncomment if you get no picture on HDMI for a default "safe" mode
    hdmi_safe=1
    
    # avoid warnings, 1 only remove overlay, 2 allos turbo
    avoid_warnings=2
    
    # hide splash rainbow
    disable_splash=1
    
    # uncomment this if your display has a black border of unused pixels visible
    # and your display can output without overscan
    disable_overscan=0
    
    # uncomment the following to adjust overscan. Use positive numbers if console
    # goes off screen, and negative if there is too much border
    
    overscan_left=16
    overscan_right=16
    overscan_top=16
    overscan_bottom=16
    
    # uncomment to force a console size. By default it will be display's size minus
    # overscan.
    #framebuffer_width=1280
    #framebuffer_height=1024
    
    # uncomment if hdmi display is not detected and composite is being output
    #hdmi_force_hotplug=1
    
    # uncomment to force a specific HDMI mode (this will force VGA). Now 720p is set (josete2k)
    #hdmi_group=2
    #hdmi_mode=4
    
    # uncomment to force a HDMI mode rather than DVI. This can make audio work in
    # DMT (computer monitor) modes
    #hdmi_drive=2
    
    # uncomment to increase signal to HDMI, if you have interference, blanking, or
    # no display
    #config_hdmi_boost=4
    
    # uncomment for composite PAL
    #sdtv_mode=2
    
    #uncomment to overclock the arm. 700 MHz is the default.
    #arm_freq=800
    
    # Uncomment some or all of these to enable the optional hardware interfaces
    #dtparam=i2c_arm=on
    #dtparam=i2s=on
    #dtparam=spi=on
    
    # Uncomment this to enable the lirc-rpi module
    #dtoverlay=lirc-rpi
    
    # Additional overlays and parameters are documented /boot/overlays/README
    
    # Enable audio (loads snd_bcm2835)
    dtparam=audio=on
    #gpu_mem_256=128
    #gpu_mem_512=256
    #gpu_mem_1024=256
    #overscan_scale=1
    
    # Overclocking (moderate)
    #dtparam=sd_overclock=100
    #arm_freq=1300
    #core_freq=500
    #over_voltage=5
    #sdram_freq=400
    #gpu_freq=400
    gpu_mem=256
    #sdram_schmoo=0x02000020
    #over_voltage_sdram_p=6
    #over_voltage_sdram_i=4
    #over_voltage_sdram_c=4
    #v3d_freq=500
    #h264_freq=333```


Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.