Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

Amiberry - Cannot Exit Emulator With Hotkey



  • Hi, I'm using a bluetooth Xbox One controller with my Pi 3B+ and Retropie 4.4. I have the following questions regarding Amiga Emulation on this setup.

    1. Can an Amiga mouse and joystick/pad be mapped to the same controller (in this case an Xbox One 2016 controller)?

    Even the CD32 used four buttons + two shoulder buttons + one start button and a dpad. that leaves both the analogue sticks and three buttons ('select' and the two trigger buttons) spare. Ideally I think it would be best if I could map the mouse 'ball' to the right analogue stick (the left analogue stick would mirror the dpad) and the left and right mouse buttons to the respective left and right trigger buttons. This way I could get past most Amiga 'crack intros' without resorting to a separate mouse attached to the Pi.

    1. Similarly, it is possible to map keyboard keys e.g. space and return to the controller?

    2. Do any of the existing Amiga emulators accept the Hotkey+Start combo to exit to the menu? If so how do I set it up?

    Thanks

    [edit] title updated.



  • @George-Spiggott I would highly recommending using Amiberry and the WHDLoad Booter which uses .lha files (which don't have the crack intros to navigate).

    You can find documentation on setting it up at the link below.
    https://github.com/midwan/amiberry/wiki/Using-Amiberry-WHDBooter-with-RetroPie

    Amiberry makes use of RetroArch configurations so that it is possible to use Hotkey+Start to quit the emulator. Other hotkey functions are also available. More info at https://github.com/midwan/amiberry/wiki/RetroArch-Commands.

    Amiberry comes with pre-determined game-specific settings so that, for games that require a mouse such as Cannon Fodder, Amiberry should automatically map the mouse to the left analog stick. It is also possible create your customised settings if you wish. More info at https://github.com/midwan/amiberry/wiki/WHDLoad-Auto-booting#game-specific-settings-improving-game-compatibility

    And it is also possible to map keyboard presses to buttons on a controller. More info at https://github.com/midwan/amiberry/wiki/Customised-Controls



  • Thanks, I'm still plugging away at this. I was getting an error "runme.exe unknown command". I replaced and renamed the Kickstart roms which stopped that but I'm now getting " AROS - AROS Research Operating System..." message and a command prompt but the game does not start.

    Can anyone enlighten me please?



  • @George-Spiggott I assume you have installed Amiberry? Could you give the filename of the game you are attempting to launch as well as its filesize?



  • Hi, I should have been clearer, Amiberry is installed. These are errors AmigaDOS is throwing up after the Amiga boots (dark grey, light grey, white screen) when I attempt to load a game from Retropie.

    The file is called: AlienBreedSpecialEdition_v1.0_0615
    Filesize is: 1,200,184 bytes according to Windows Properties (read from the Pi over the network).

    I'm getting an AROS copyright message and a DOS prompt but the game does not load.



  • @George-Spiggott I believe the file you have has a .zip extension. These files loading to the Amiga DOS screen is a known problem - see here.

    I would recommend using .lha archives but please make sure you read the section on installing game data files at the Amiberry wiki first to optimise compatibility .



  • Thanks that fixed it. I found a handy online converter for .zip to .lha here: https://convertio.co/pricing/?utm_source=hit_dm

    One little quirk. Sometimes if I rename a game (so it looks better on the Retropie menu screen) it stops working. Is there config file to edit to fix this?

    I haven't sorted using the hotkey to exit yet but I'll take a good look at the instructions in the link later.



  • I'm still having a little trouble with quitting out of games with hotkey + start with my Xbox One bluetooth pad.

    I've created a file called controller.cfg in retropie/configs/amiga/amiberry folder.

    The file contains the following text ('10' is the 'Xbox' button, '9' is the 'start' button).

    input_enable_hotkey_btn = "10"
    input_exit_emulator_btn = "9"

    Can anyone help?



  • @George-Spiggott Can you confirm that the hotkey+start combination work in other RetroArch emulators such as those for NES or SNES?



  • @dudleydes Yes it works on all my other emulators (MAME, PS1, N64, Sega CD, SNES etc.)



  • @George-Spiggott Thanks.

    Could you check that your RetroArch controller map has been recognised by Amiberry? Launch the +Start Amiberry script, navigate to the Custom controls panel and check that there is a [R] next to your Input Device name as shown here.



  • @dudleydes Hi and thanks.

    I took a look in the Amiberry (version 2.21) settings and they do indeed show an [R] to the right of the controller.

    While I was in there I noticed that there is a controller config path in the paths panel. It points to an ...amiga/amiberry/controllers/ folder. I created a folder in that location and moved my controller.cfg file there.

    I also double checked the button numbers (using retropie's controller config. my original button numbers were wrong. I have modified them accordingly (below):

    input_enable_hotkey_btn = "16"
    input_exit_emulator_btn = "11"

    I also noticed that Amiberry loads with a config with the hotkey option (shown on the page you linked to) not selected. Since I couldn't get Amiberry to keep any changes I made to that option (or any others) after a reboot. I changed the default emulator for all games from Amiberry to the Amiberry 1200 AGA setting which does have the hotkey option selected.

    Sadly still no luck getting it to work though.

    I believe that Amiberry is pulling Amiga specific keypad configs from somewhere though as some games have pause and other options that were keyboard presses assigned to the pad e.g. in Xenon transform ship/tank can be done with a button press (it was the Space Bar on my old Amiga).



  • @George-Spiggott said in Amiga Emulation: Combining Pad and Mouse onto one Controller:

    I believe that Amiberry is pulling Amiga specific keypad configs from somewhere

    Could you check that there are no superfluous .uae files in /opt/retropie/configs/amiga/amiberry/conf? The only .uae files that should be present are the following (though I believe these are no longer required by Amiberry):

    • rp-a1200.uae
    • rp-a1200.uae.rp-dist
    • rp-a500.uae

    Please remove any others and see if that fixes your hotkey issue.

    Creating a controller config in /opt/retropie/emulators/amiberry/controllers will have no effect. (Did you try this after reading this page? If so, then notice that there is a space between 'Controller' and '.cfg'.)

    If you run the command ls -la /opt/retropie/emulators/amiberry/controllers, you will notice that the folder is symlinked to /opt/retropie/configs/all/retroarch/autoconfig . This is the folder that stores the RetroArch configs for your controller(s) when you first configure them in EmulationStation.

    (If you run ls /opt/retropie/emulators/amiberry/controllers, then you will get a list of the RetroArch configs, including one for your Xbox One controller.)

    The fact that a hotkey has not been selected in the Custom controls panel of the Amiberry GUI suggests the symlink may be broken. When you run the ls -la command above, is the symlink blue or red? If it is red, then symlink is broken. You can confirm by running the command:

    ls /opt/retropie/emulators/amiberry/controllers
    find -xtype l -ls
    

    The command will only list broken symlinks so if there is any output from the command, then you have broken symlinks.

    If the symlink is broken, then you can go to the Paths panel in the GUI and press Rescan Paths. If this does not work, then I suggest raising an issue at the Github page where the devs should be able to help.



  • @dudleydes Thanks again. Sadly still no luck.

    There are no additional .uae files (only rp-a1200.uae and rp-a500.uae) There's also adfdir.conf and retorarch.cfg

    I tried adding a space to ...controller/controller.cfg. That didn't work either. I have deleted the controller folder and file I created.

    Ls - la gives me a light blue ...amiberry/controllers and a purple ...retroarch/autoconfig output. I assume that is ok.

    find -xtype lists and atari i800 cfg file. I assume this is both broken and not relevant to the Amiga controls. I re scanned paths anyway. no result.

    Is there a config file Amiberry reads from when it loads? Perhaps something is awry there.



  • @George-Spiggott In the Misc panel in the Amiberry GUI, could you check that Use RetroArch Quit Button is selected?



  • @dudleydes Yes both that and RetroArch Menu are selected. Research reset is not.



  • @George-Spiggott I'm afraid I'm out of ideas. All I can suggest is to report your issue at the Amiberry Github page detailing the checks you have made in this thread.

    There was another thread started last week with a similar issue so it may be a bug.



  • @George-Spiggott I thought I would look over this thread to see if there was anything I had missed.

    You mentioned that:

    I also noticed that Amiberry loads with a config with the hotkey option (shown on the page you linked to) not selected. Since I couldn't get Amiberry to keep any changes I made to that option (or any others) after a reboot...

    Could you launch the Amiberry GUI using +Start Amiberry and then in the Custom controls panel, could you try selecting a hotkey and buttons for Quit and Menu, if not selected? Please make sure that Hotkey is selected in the Function Key part of that panel.

    Next, navigate to the Configurations panel, check that the name at the bottom is uaeconfig and then press the save button.



  • @dudleydes Hi. Tried that. It saves the config but when I go back in hotkey is not selected. Even if I reload the configure file.



  • @George-Spiggott Could you check the uaeconfig.uae file that you should be able to find in /opt/retropie/configs/amiga/amiberry/conf that it has the following lines:

    amiberry.use_retroarch_quit=true
    amiberry.use_retroarch_menu=true
    amiberry.use_retroarch_reset=false
    


Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.