Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

Amiberry - Cannot Exit Emulator With Hotkey



  • @George-Spiggott said in Amiga Emulation: Combining Pad and Mouse onto one Controller:

    I believe that Amiberry is pulling Amiga specific keypad configs from somewhere

    Could you check that there are no superfluous .uae files in /opt/retropie/configs/amiga/amiberry/conf? The only .uae files that should be present are the following (though I believe these are no longer required by Amiberry):

    • rp-a1200.uae
    • rp-a1200.uae.rp-dist
    • rp-a500.uae

    Please remove any others and see if that fixes your hotkey issue.

    Creating a controller config in /opt/retropie/emulators/amiberry/controllers will have no effect. (Did you try this after reading this page? If so, then notice that there is a space between 'Controller' and '.cfg'.)

    If you run the command ls -la /opt/retropie/emulators/amiberry/controllers, you will notice that the folder is symlinked to /opt/retropie/configs/all/retroarch/autoconfig . This is the folder that stores the RetroArch configs for your controller(s) when you first configure them in EmulationStation.

    (If you run ls /opt/retropie/emulators/amiberry/controllers, then you will get a list of the RetroArch configs, including one for your Xbox One controller.)

    The fact that a hotkey has not been selected in the Custom controls panel of the Amiberry GUI suggests the symlink may be broken. When you run the ls -la command above, is the symlink blue or red? If it is red, then symlink is broken. You can confirm by running the command:

    ls /opt/retropie/emulators/amiberry/controllers
    find -xtype l -ls
    

    The command will only list broken symlinks so if there is any output from the command, then you have broken symlinks.

    If the symlink is broken, then you can go to the Paths panel in the GUI and press Rescan Paths. If this does not work, then I suggest raising an issue at the Github page where the devs should be able to help.



  • @dudleydes Thanks again. Sadly still no luck.

    There are no additional .uae files (only rp-a1200.uae and rp-a500.uae) There's also adfdir.conf and retorarch.cfg

    I tried adding a space to ...controller/controller.cfg. That didn't work either. I have deleted the controller folder and file I created.

    Ls - la gives me a light blue ...amiberry/controllers and a purple ...retroarch/autoconfig output. I assume that is ok.

    find -xtype lists and atari i800 cfg file. I assume this is both broken and not relevant to the Amiga controls. I re scanned paths anyway. no result.

    Is there a config file Amiberry reads from when it loads? Perhaps something is awry there.



  • @George-Spiggott In the Misc panel in the Amiberry GUI, could you check that Use RetroArch Quit Button is selected?



  • @dudleydes Yes both that and RetroArch Menu are selected. Research reset is not.



  • @George-Spiggott I'm afraid I'm out of ideas. All I can suggest is to report your issue at the Amiberry Github page detailing the checks you have made in this thread.

    There was another thread started last week with a similar issue so it may be a bug.



  • @George-Spiggott I thought I would look over this thread to see if there was anything I had missed.

    You mentioned that:

    I also noticed that Amiberry loads with a config with the hotkey option (shown on the page you linked to) not selected. Since I couldn't get Amiberry to keep any changes I made to that option (or any others) after a reboot...

    Could you launch the Amiberry GUI using +Start Amiberry and then in the Custom controls panel, could you try selecting a hotkey and buttons for Quit and Menu, if not selected? Please make sure that Hotkey is selected in the Function Key part of that panel.

    Next, navigate to the Configurations panel, check that the name at the bottom is uaeconfig and then press the save button.



  • @dudleydes Hi. Tried that. It saves the config but when I go back in hotkey is not selected. Even if I reload the configure file.



  • @George-Spiggott Could you check the uaeconfig.uae file that you should be able to find in /opt/retropie/configs/amiga/amiberry/conf that it has the following lines:

    amiberry.use_retroarch_quit=true
    amiberry.use_retroarch_menu=true
    amiberry.use_retroarch_reset=false
    


  • @dudleydes Yes that is what is written in the config file.

    I've been experimenting with the .uae configs and I've discovered that while they are deleted games no longer are able to use extra buttons on the joypad e.g. Xenon's transform button (space bar). Also that I cannot seen to effect any change that is picked up after I exit, including fullscreen mode.

    I think that the setup for games is held in the file /opt/retropie/configs/amiga/amiberry/whdboot/hostprefs.conf In that file quit, menu and reset are all set to true. They are preceded by a semi colon, what does that mean? I tried it with the semi-colon deleted but it made no change.

    Also changed the thread title to reflect my current issue.



  • *Temporary Fix *

    Well I finally got to the bottom of this. Amiberry does not register when button 15 (select) or 16 (xbox) are pressed on an Xbox One 2016 Bluetooth pad (maybe some other Xbox pads as well). The short term solution is to assign the Hotkey to another button that is not used in Amiga emulation e.g. 14 (right analogue press).

    Is it possible to make a dedicated Amiberry joypad config file in Retorarch that only Amiberry will pick up on. While I'm at it could I do the same for other emulators such as LR PCSX Rearmed?

    Thanks to Horaceandthespider at Github for help in resolving this.



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.