Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

Scummvm built from Source for PS3 controller has slow mouse speed compared to standard binary



  • Hi,

    I use a PS3 bluetooth controller with my Retropie setup. Recently i added scummvm games as well and had to find out that the standard button layout is less then steller for PS3 controller in Scummvm under Retropie. After some searching i found out that in order to change the PS3 button layout i had to build it from source since the buttons are hardcoded. I successfully managed to build my own version where the mapping is now good however the mouse cursor speed is slower compared to the original scummvm version that you can download from the repo (which has the shitty PS3 mappings).

    Anyone know what is causing this? I assume this is probably another thing that would need to be changed in the config before building from source however neither of the guides i found related to this remapping and building from source solution mentioned this.

    Any help would be appriciated.

    Cheers



  • @Freakadude Which version of ScummVM are you using? The mouse issue was resolved when version 2.0 of ScummVM was released.

    Is your RetroPie setup based on the 4.4 Stretch image? The button numbers for PS3 controllers changed with the release of Stretch so there should be no need to remap. This should be the new mapping for PS3 controllers.



  • @dudleydes I am running stretch currently with latest updates. When i use the binary thats updated from retropie it still gives me the old PS3 mapping (select button is the left mouse etc). So i built scummvm from source about 2 hours ago but there i have the mouse issue after the mapping is fixed.



  • @Freakadude Which version of ScummVM has been installed? If you launch the +Start ScummVM script from ES, it should say in the GUI.

    If it's not version 2.0, then update the RetroPie setup script and rebuild from source.



  • @dudleydes Its ver 2.0.1.pre.



  • @Freakadude the new lr-scummvm libretro core version of ScummVM was finally added to official RetroPie today, so maybe you can give it a try :) Being RetroArch-based means that using this version of ScummVM with gamepads is very easy and intuitive, you can use RA remappings and you can apply shaders too, and all the RA goodies.

    I still have to write the final documentation for it in the Wiki, but in the meantime you can read how to setup your games from this topic (ADDING SCUMMVM GAMES section): https://retropie.org.uk/forum/topic/19693/lr-scummvm-request-for-comments-and-testing

    You can skip the installation of the experimental scriptmodule as it is now part of RetroPie. Just make sure you update RetroPie-Setup and then you can access lr-scummvm in the experimental section. This will rcompile the core from source, so will take some time, but once done you don't need to recompile it anymore.
    If you have any issues, just leave comments in the mentioned thread. Cheers!



  • @hhromic Cheers for the info. I will check out out asap and give feedback. Thx!



  • @Freakadude no problem!
    Keep in mind that the scriptmodule configures everything out of the box after installation, you just need to prepare your game directories. You don't need to manually add any games in the ScummVM GUI.

    Also keep in mind that if you have the standalone ScummVM installed, probably you will see two entries for each game in EmulationStation (one for the game directory itself and one for the standalone svm files). The lr-scummvm core must be launched using the game directory entry so make sure you launch the correct one.



  • @hhromic Yeah i have read the adding games part of your tutorial so i will add the games accordingly. Thx again!



  • @hhromic So i installed the LR-Scrumm version. I copied over a sample game (Maniac Mansion). Named the directory Maniac Mansion.svm. Put inside the folder an svm file named maniac-v2-amiga.svm with one line "maniac-v2-amiga". It shows up in the emulation station menu and when trying to launch it (and setting lr-scummvm as the selected emulator for this instance) nothing happens and i just get returned to emulationstation. Am i missing something?



  • @Freakadude maniac-v2-amiga doesn't seem to be a valid gameid, perhaps you mean just maniac?
    The gameids must be in the ScummVM compatibility list: https://www.scummvm.org/compatibility/



  • @hhromic Well i have multiple versions and there was this type of differentiation in the normal scummvm emulator under retropie so i assumed this would be the case here as well. Anyway i renamed the svm file inside the folder to "maniac.svm" and changed the line also to "maniac". Did not help...



  • @Freakadude can you launch the game using verbose logging active and posting back the log in /dev/shm/runcommand.log ?



  • @Freakadude multiple versions of games should be supported by the lr-scummvm core too, you can have the same .svm file with the same gameid inside for more than one game directory. This file only tells the emulator which engine to use for the game data of the directory launched.



  • @hhromic It works now. It seems between changing the svm file somehow the retroarch config deleted the rom specific setting to launch this version with the lr-scummvm core. I now selected it again manually and now it started up normally. PS3 mapping works nicely and the mouse speed also is good. So far so good! :) Will convert all my games to this setup and see how it goes :) Any advice on how to store the videosnaps and images related to this setup? I had manually done all the items for the old version as most scrapers don't really work well with scummvm.



  • @Freakadude happy to hear it worked!

    Regarding the snaps, if all the game directories are named with .svm, then EmulationStation will see them as "regular roms". Then I used the internal ES scraper and after accepting the warning of scummvm being an unknown platform, it scraped my games normally like any other ordinary rom file.
    If you did it manually, just use the directory names (without .svm "extension") as the item entry, like any other ROM.

    If you have more testing feedback, please post it on the dedicated thread :)
    Good luck and thanks for testing! (and happy playing!)



  • @hhromic After a quick check regarding the snaps and info i think the easiest way will be to simply do a quick edit on my existing gamelist.xml as that seems to do the trick just fine. :)



  • @hhromic One more quick check. I noticed in your other documentation you also describe setting up MT-32 Emulation. Ist that guide also relevant for here or is it already integrated somehow?



  • @Freakadude yes, the scriptmodule compiles MT-32 support into the lr-scummvm core, but is not enabled by default because the RPI is not very powerful for it in some games.

    If you want to try it, go to the BIOS directory ($HOME/RetroPie/BIOS) and in there you will find the configuration file scummvm.ini.

    Once in there, set these options in the [scummvm] section (if not there, add them):

    mt32_device=mt32
    music_driver=mt32
    

    To return to the default (disabled), delete the options from the config file.

    Edit: forgot to add an option to the list :)



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.