Please do not post a support request without first reading and following the advice in

[SOLVED] Doom - exits to Retroarch RGUI, not Emulationstation

  • Hi folks, another one I'd appreciate a bit of help with.

    I got Doom installed and up and running on my 3B+ with 4.4.3 and it runs really nicely. I'm using the separate savegame scripts to launch each title (excepting the default shareware one) from here. The code is below, and I've modified it with the correct names and locations as per each title. This is using lr-prboom:

    unzip -qq -o "${path}/savegames_${wadfile%.*}.zip" -d "$path"
    "/opt/retropie/supplementary/runcommand/" 0 _PORT_ "doom" "${path}/$wadfile"
    cd "$path" && zip -mj "savegames_${wadfile%.*}.zip" prbmsav?.dsg

    However, when I quit each game, rather than returning me to Retropie's Emulationstation GUI, it's taking me to the Retroarch RGUI, and I'm having to quit from there. Is there a more elegant way to launch these titles that doesn't do this? I tried the other method on the above page that doesn't keep the saves separate but that resulted in the games not launching at all.

    Thanks in advance for any help you can share. :-)

  • I'm an idiot. I'm using lr-prboom, which is a Libretro emulator. Just use select+start to exit to Emulationstation. Use "quit game" in Doom to exit to Retroarch.

    Move along people...

  • @Ranma You are the first one that reports the script is working. Does nobody cares about the issues with savegames if you have several wad files in folder?
    So this was one of my first attempts in coding ;) Nowadays I would avoid zip...

  • Well it seems to be working OK so I have no complaints. :-) Naturally, if you have a better way of doing this now we'd all love to see it! ;-)

    Thanks for the help. :-)

Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.