Please do not post a support request without first reading and following the advice in

MYGT controller stopped working

  • Pi Model or other hardware: 3B+
    Power Supply used: 5v 2.5a
    RetroPie Version Used 4.4
    Built From: Pre made SD Image on RetroPie website
    USB Devices connected: keyboard
    Controller used: MYGT MY-CO3

    I'm fairly new to this but learning lots. Anyway I have followed the instructions from and downloaded the boot image from there. First attempt everything went well and I was able to get the controller configured then install 1 NES game. I played it to confirm it worked then installed 2 more games then it quit working. It will boot up to the ES welcome page which shows the gamepad detected but pressing a button doesn't work. Pressing f4 takes me off that where I get an error message of addjoystickdeviceindex assertion"joy" failed. Some times the keyboard fails so I have to SSH to reboot.

    I have formatted and flashed several SD cards and removed all the games but still get this same error. Jstest shows that the controller is off. This controller will work on my PC. I have read all the pages on the wiki and searching the forum also Google and YouTube. Haven't found a fix for it. I have tried a bunch of things that haven't worked so far and out of ideas.

    I am waiting for a usb receiver so I can use my Xbox 360 controllers and hope they work but in the meantime I'd like to figure out a fix for the MYGT. Any help would be greatly appreciated

  • Global Moderator

    @j_hadden If the controller is not responsive via jstest, then it's not detected by the OS and would not work. I see this controller has multiple connection modes - Windows / PS / Android - did you maybe switched the connection mode ? That would explain why the controller is not recognized any longer.
    EDIT: is it really a Bluetooth controller or it has a wireless USB dongle ?

  • @mitu
    I have tried switching through all the modes with no luck. Initial install I configured it with pc mode and it worked.

    It has a usb dongle which I had been using. I found the paper work and it does have Bluetooth. I just got that set up. It will connect however it shows no game pad connected. If I hold a button down it recognizes it as a keyboard and doesn't configure correctly.

  • Global Moderator

    @j_hadden Using it as a keyboard is no fun. Try switching it to PS (not pc) mode and use the dongle, if it's PS compatible it should report itself as a gamepad. Does it have any reset (mode) to start over ?

  • @mitu
    I have tried going through all the different modes on the controller and both with the dongle and with Bluetooth. I've also tried a couple different drivers with no luck so far. It doesn't have a reset but can switch between dinput and xinput. Neither of which works. Im running retroarch on my PC and it works flawless on that

  • Global Moderator

    @j_hadden OK, switch it to dinput and use the USB dongle, then connect the controller. Exit Emulationstation, then run from the terminal the following commands

    cat /proc/bus/input/devices

    and paste the output of both commands in the topic.

Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.