Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

Some buttons not responding during PS controller configuration



  • Pi model: 3B+
    Power Supply Used: 5v, 2.5A (Part of Smraza Case kit)
    RetroPie Version Used: 4.4, Emulationstation V2.7.5RP
    Built From: Pre made SD card image on RetroPie website - retropie-4.4-rpi2_rpi3.img
    RetroPie USB Devices Connected: Logitech USB keyboard
    Controller Used: SCPH-10010 (PlayStation 2 Controller) and USB adapter (Mcbazel PlayStation 2 Controller to USB Adapter)

    Hello all,

    I just want to preface this post by saying I am brand new to the Raspberry Pi community, so I apologize if I am possibly overlooking a simple mistake or user error. I am still learning. My issue is that a few buttons on my PS2 controller seem to be unresponsive while setting up the Gamepad.

    I booted up my Pi for the first time last evening, and everything went through smoothly. I had my PlayStation 2 controller hooked up to the Pi via the following adapter I bought on Amazon (https://www.amazon.com/gp/product/B000NJBD90/ref=oh_aui_detailpage_o00_s00?ie=UTF8&psc=1). When the Pi booted up, I received the screen that 1 Gamepad had been detected. I pressed the start button and the text “SONY PLAYSTATION(R) 3” came up at the bottom of the Welcome menu before it launched the controller configuration. I made it through the D-Pad, start, and select buttons before I ran into problems. To configure the A button I pressed the (circle) button on the PS2 controller and there was no response, I tried both the (X) and (square) button after that and received no response from those buttons either. Wanting to know if any other buttons on the Gamepad worked I started pressing each remaining button, and all shoulders, triggers, joysticks, and the (triangle) button worked just fine. Does anybody have any ideas as to why the (circle), (X), and (square) button are not responding? Not sure if this is a controller/adapter issue, a Pi issue, or even a power supply issue.

    Some things I have already tried: I plugged in my old PS2 to test the controller and all buttons were responsive. I also tried moving the controller usb to each of the 4 different ports and get the same result each time. Another note, the Analog light is on, and it seems I can’t turn it off while configuring the controller.

    If anybody is able to help it would be greatly appreciated. If you need any other information please just let me know, but you may have to help me in where to find that info.

    Thanks!


  • Global Moderator

    You can test if the buttons are registered by exiting Emulationstation (F4 or from the Emulationstation menu choose Quit) and executing on the command line

    jstest /dev/input/js0
    

    The command will show you what buttons/joysticks are detected and their state. You can press the problematic buttons to see if they are registered. More details here.



  • Thank you for the information and the quick response. I used jstest and it shows that the controller only has 13 buttons, instead of the 16 a ps3 controller should have. Still no response from the 3 buttons I mentioned earlier during the test. Correct me if I’m wrong, but I believe this points to it being a controller issue.

    Thanks again for all of your help.


  • Global Moderator

    @AJ2425 said in Some buttons not responding during PS controller configuration:

    Correct me if I’m wrong, but I believe this points to it being a controller issue.

    Well, if the controller works with your PS2, then it's an adapter issue - you might want to get that checked - or try it also on a PC.



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.