Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

Dosbox Games Running at low Resolutions (Tiny Game Screen)



  • Hello! I'm have great success getting some of my old dos games working on my Retropie through Dosbox. I hit a snag when I tried running Settlers 1 (Serf City: Life is Feudal). When the game starts, it's displayed in a very small resolution (320x240 maybe?) at the center of the screen.

    Here's my config file I use to launch the game:

    output=opengl
    fullresolution=0x0
    
    [joystick]
    timed=false
    
    [autoexec]
    # Lines in this section will be run at startup.
    # You can put your MOUNT lines here.
    
    mount c "/home/pi/RetroPie/roms/pcdos/Settlers"
    c:
    serf.exe
    

    I've tried a few other options other than the fullresolution and output settings, but nothing as worked so far. When i search for solutions online, most of the fixes are for PC's or aren't relevant to my situation. Has anyone else come across this before? How do I run this game at a larger resolution?



  • I believe these are the lines you need to look at.
    In this file --> dosbox-SVN.conf

    Found here --> /opt/retropie/configs/pc

    fullresolution=
    aspect=
    scaler=

    Use your monitor's native resolution for the first option.
    Use aspect=true, if you want the correct aspect ratio - after scaling. False, if you want it stretched to fill your monitor.
    scaler=XXXX - XXXX=your scaler of choice...none, normal2x, normal3x, advmame2x,....etc... Use this to scale the image.



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.